Accessing home server from WAN

Hi,
I could need some help with this problem I’m having. I’ll admit right away I dont know much about networking and VPNs so please bear with me. I will also try to explain everything in details so to give a clear picture of my case.

My setup is as follows (pretty basic):

  • A cable modem/router working in bridged mode. Provided by the ISP when I upgraded my connection.

  • ASUS RT-AC66U Wi-fi router

  • Wired devices: Desktop computer, Home server, Android TV, AV Receiver, etc all with mapped IP address (through DHCP address reservation)

  • Various wi-fi devices

I wanted to connect only two wired devices on my LAN (Android TV & Home server) to the VPN.
I decided using my ASUS router’s VPN feature to do that.

I followed the guide here: https://support.goldenfrog.com/hc/en-us/articles/222083028-VyprVPN-OpenVPN-Setup-for-AsusWRT

All in all pretty easy. Thanks to the feature of AsusWRT-Merlin firmware I was able to specify which devices I wanted to have their traffic routed through the VPN.

The two devices are now connected through the VPN.

However the problem is that I am not able to access my home server from WAN anymore.

I tried to do as I did before, just typing the Public IP and specify the port (I have portforwarding rules created for that) but to no avail. It worked perfectly before I started using the VPN but it doesnt anymore.

I disabled NAT Firewall on my VyprVPN account, no dice. I created a DDNS account and tried to access my server through that, nope (I am able to access my router’s web admin though).
Could the problem reside on the modem/router? Or I overlooked some settings in my router?

Could someone give me a hand here? I’m quite lost, I’m sure the solution is round the corner but I cannot find it.

Thanks in advance

Hello,

Thank you for bringing this matter to our attention. I would like to preface this by saying that your configuration is a non-standard setup, so we cannot guarantee it will work and support will be limited. With that said, we would like to troubleshoot this issue with you via our email support channel. I’m not able to locate an account for you, so please reach out to us here:

https://www.goldenfrog.com/contact-support

Please include the email address associated with your account on the form.

We look forward to assisting!

Regards,
Logan
Golden Frog Technical Support

I am having exactly the same issue as tahini as I cannot get the port forwardings for my services into my LAN to work. Can someone please help me resolve this issue as otherwise I cannot use the VPN. Thanks.

Hello @Steggl

Sorry to hear you are having trouble with that, we cannot guarantee this will work, and support is still limited. If you can reach out to our support team with your account information, and some details we can look into the matter.

https://support.goldenfrog.com/hc/en-us/requests/new

Regards,

Thanks Kane, opened up ticket # 4166730