Android App on 5.1

Hi, I signed up to vypr a few days ago. It works great on my phone. I’m trying to use the app on my android box running 5.1. After log it the screen goes white and boots me out. Help!

Hello @Ashley_Harrison,

I am sorry to read that you are experiencing such issue. I would like to collect some additional information.

  1. What it is the make and model of your Android box?
  2. Do you experience the issue on any other Android device? What is the other Android device?
  3. Does the issue continue after a full uninstall, restart of the device, and reinstall of the VyprVPN app?


Hi Samuel,

It’s an M8S Android box. It runs Android 5.1. I don’t have a problem using with any other app on the box just the vypr app.

I have just uninstalled > rebooted box > reinstalled the app. Still no joy.

After entering my log in details it looks like it is trying to load into the app. Then I get a white screen and returned to the home screen.


I have exactly the same issue on a Minix NEO U1 with Android 5.1.

I tried to clear the data, uninstall it, reboot, install it again…but nothing! It starts the first time, ask for my credentials and then just a white screen flashed for less than a second and back to the home. It is the only one app that does not start and do this.

Same problem here - Android 5.1.1, Beelink M18 TV Box. Installed from sideloaded apk and when that only allowed me to enter my credentials before kicking me out to the homescreen, I tried installing from the Google Play Store which still kicks me back to the homescreen.

It basically looks like exactly the same thing is happening as has been reported by Ashley and Alek above …

MX-Q Pro 4k tvbox Lollipop 5.1.1 same issue.

Exactly the same issue on Beelink MiniMXIII: Android 5.1, Amlogic S905 Quad Core 64-bit ARM Cortex-A53 processor with the Penta-core ARM Mali-450 graphics engine.


Upon investigation of this issue by our QA and Development Teams, they have identified the cause of this issue and are working on a resolution. At this time, we do not have an estimated time as to when a resolution will be reached and pushed out. Once we do know, we will update this forum post to let everyone know.

Thank you all for your patience in this matter!

Thank you Samuel for your feedback. I can add myself to the list of the users having the same problem (Minix Neo U1 - Android 5.1.1).
I hope a fix will be released soon.

Hello @Ashley_Harrison, @alek_05, @Fent, @DirtyDog995, @Ursus, and @cernus,

We are pleased to announce that our latest version of the VyprVPN app for Android should resolve the issue you are experiencing. Please uninstall the current version of VyprVPN that you have installed, restart your Android device, and then download and install the latest version ( of the VyprVPN app from the Google Play store.

Please let us know if you continue to experience this issue.


Seems to be working now. I didn’t try yet to connect to a VPN, but I can start the app and login now, that was impossible before.

Thank you.

Hello @alek_05,

We are glad to hear this! Should you run into any issue connecting to the VPN, feel free to reach out to our 24/7 Support Team, who will be able to assist you in troubleshooting, via chat or email at

Best Regards,