Anonabox Problem VPN Status Connected but No IP adress

I ordered 2 anonabox pro, I think there is a problem with the vpn, connnection STATUS OK for vyprvpn and but no IP IP ADRESS: undefined.I updated the firmware, I made a reset.The problem I do not have internet withethernet or wifi .[image] I need your help !!!
I Need Your Help !!!

On the dashboard I connect to paris but with my router anonabox I do not have internet because the router can not get IP address from the servers VYPRVPN I tried the 2 protocols, another server from other countries the same thing, status VPN connected and IP ADRESS indefined.
What should I do ?

Same problem and no solution or answer can be found on Google.

Hello, @caspersnyman and @Frederic_Elbaz

I’m sorry to hear of the trouble.

Are you able to connect if you use the VyprVPN desktop or mobile applications?

Are you running any firewalls over your router?

Can you please describe to us how you have your network set up? (Example; modem > router > ethernet > pc)


Golden Frog Technical Support

Hi Logan. Our Anonabox is connected to our WiFi router with no firewall. We don’t have an outgoing firewall blocking any traffic as far as we can see. The problem seemed to have started a few weeks ago. If we go to, it does seems to show us a public IP address. Also, if we disable VyprVPN on the Anonabox, the ping is lower. Once VyprVPN is enabled, the ping is higher. We can browse the internet whether VyprVPN is on or not. When it is on, it does work slower because of the latency the VPN creates.

Hello, @caspersnyman

Thanks for getting back to us. So, from what I understand, VyprVPN is successfully connecting for you, but it is simply not showing the connected IP address on the Anonabox page?

If that is the case, does this occur across multiple browsers? Does it persist if you clear the cookies and cache within your browser?

This may simply be a UI issue with the Anonabox firmware.

Golden Frog Technical Support

Hi Logan,

I’ve tried to clear caches in Internet Explorer, Firefox and Chrome. Still the same. It shows this:

I’ve also tried reflashing with previous firmware versions without any change. Current firmware is 4.3d which I have reinstalled. I’ve even reset the Anonabox to defaults and reconfigured it mutiple times. All was working up to about a month ago. It’s as if something externally changed.

When I do a ping to an external server without Vypr, the XXms is quicker (30ms fo example). When I enable Vypr and ping, the XXms is more (500ms for example), so it does seem to connect - I can browse the internet. Also, on the Vypr website, it shows the connection as connected. On the Anonabox it still shows undefined. When I SSH into the Anonabox, it shows TUN0 as 10.x.x.x when I do IFCONFIG and not the Public IP I pick up using When I start up Netflix, it shows that I’m using a proxy. I suspect it has something to do with the 10.x.x.x IP. It should show something like 69.x.x.x or 208.x.x.x depending on the Vypr server I select. I’ve tried New York and Washington as well. Some of the other US servers on the list don’t work - they show Disconnected.

Not sure if this info will help you.

Best regards,


Hello, @caspersnyman

If the VPN is connecting successfully and you are able to confirm such, then I believe this is simply a UI issue with Anonabox. We have made no changes on our end that would cause such an issue. Does the same issue occur if you switch to OpenVPN 256 rather than 160?

I do not believe the issue you are having with Netflix is related. Netflix and other streaming services actively work against VPN users and will consistently place restrictions on known VPN IP addresses. I would simply recommend disconnecting and reconnecting until you receive an IP address that is not currently blocked by Netflix. While we do work to combat VPN blocking such as this, we cannot guarantee all sites and services will work at all times due to factors beyond our control.

Golden Frog Technical Support

sorry for my english, I use your vpn for my connection abroad with the anonabox router and a french box in ethernet .
I have exactly the same problem as caspersnyman and I see a very slow internet flow and my French box doesn’t work because the speed is too slow, my connection internet wan is very good i have 1gbps.
Before it works but today it does not work anymore.
I tried with one of your competitor on the anonabox and it works much better.
Could you check on your side

Hello @Frederic_Elbaz,

Please contact our support team for assistance.

This thread did not address problems with speeds. Do you mean your router is not receiving an IP address? If so, please include that information in your ticket or chat and we will be glad to assist!

Hi Logan,

Thank you. So I would assume the fact that it doesn’t show an IP address, should not be the main issue, as it does seem to connet fine. And yes, both 256-bit and 160-bit settings have the same effect. I’ll have to do some checking to see if we can get Netflix working though as you recommend.

Hello @caspersnyman,

Let us know the results of trying Logan’s steps out. We also have some more steps you can try on our support site at: