Cause and Solution: connection button on MAC OSX app doesn't work

the connect button of v2.16 works well but connection fails frequently now.
I downloaded v2.17 and v2.18, but the connect button don’t response, as described on this post.

the last reply of this post gave the reason and solution
https://forum.goldenfrog.com/t/vypr-vpn-mac/4326/12

vyprvpn mac app uses api.goldenfrog.com to get ips of the servers.
if it fails to connet api.goldenfrog.com, the connect button doesn’t work.
the solution is as follows:
step 1: the iOS version works well. so you just open it and connect.
step 2:on the setting, look at the log. the log reads that it use IKEv2 vpn and you can see the ip.
step 3:on your mac, open System Preference -> Network.
add an IKEv2 vpn config manually
step 4:the RemoteID is *vyprvpn.com, authenticate by your vyprvpn username and password.then you can connect.

the ip won’t work for a long time.when connection fails, do step 1-3 again with a new ip.

hope the support team can fix this soon. make the mac app work like the iOS app does may help.

For god sake. Finally someone raise this problem. I have exactly the same problem for months! I emailed the support team several times , and not even a single reply that neither work or explaining the problem.
Anyway, I would have expected them fixed it already, considering the extensive time period had been.
The VPN works fine on my other devices, just have this issue on my laptop. The button doesn’t work sometime, the time it did work, it took a long time to respond.
Someone please fix it!

Hello, We have reviewed your issue and have not received an e-mail from you recently. Please make sure you have updated to the latest version of the Vyprvpn app - 2.18.0.6455 on your Mac and restart it.

If you still see the same issue, please try the following steps:

  1. Quit that VyprVPN application from the ‘Quit’ option in the VyprVPN menu at the top of your screen.
  2. To remove the service, use Command+Tab and select Finder, then press Command + Shift + G to bring up the Go To window and type in: /Library/PrivilegedHelperTools
    A window should open showing the VyprVPNService sitting there. Drag it to trash.
  3. Then you will need to log out of OS X and log back in to complete service removal.
  4. Empty the trash bin.
  5. Restart VyprVPN to prompt the reinstallation of the VyprVPNService.

Regards,

Technical Support

i downloaded v2.17 & v2.18, but the connection button don’t work very well. like Forrest said, "The button doesn’t work sometime, the time it did work, it took a long time to respond. "
I have tried your solution but it doesn’t work.
one support guy ask me to use v2.16, the connection button worked well. althought i have to try many times , I can connect to servers
but recently the connection of v2.16 is very unstable, so i try v2.17 and v2.18 again.the connection button problem still remains.
I have send the support guy videos to show the problem, if you need them ,i can record new ones.
I have show one solution to use vyprvpn on Mac on the post, I think if the Mac version follows the same behavior of iOS version, the problem will be solved

Hello.

We are sorry for this issue persists. Please send the Videos to our Support Team at support@goldenfrog.com and we will investigate further!

You can request we add features to improve our apps and service at the following link: - http://ideas.goldenfrog.com/forums/171209-golden-frog-ideas

Regards

Already tried your method but still didn’t work. I doubt the IP address in iOS VPN is not valid in Mac OS X.

Hello @Ming_Jin

If you’re having trouble connecting please contact our support team at support@goldenfrog.com or https://www.goldenfrog.website/contact-support and we will be happy to assist you!

Thank you for your patience.

I take my words back. It does work by manually configuring the server IP of VyprVPN in Mac OS VPN page. But I hope this is just a temporary solution and you guys are going to FIX the VyprVPN connection button issue.