Chameleon & Google Voice

I’m running the latest version of VyprVPN on my Moto G with Android 4.4.4. and on my desktop running the technical preview of Windows 10. Service works great for both using OpenVPN! I recently started using Google Voice on my phone and desktop. I can make and receive calls with excellent quality when I’m using OpenVPN. If I switch to Chameleon, I can’t make or receive calls at all.

Hello @skowly,

I am sorry to hear that you are experiencing an issue with making and receiving calls with Google Voice on your Moto G running Android 4.4.4 when using the Chameleon protocol. Please contact our 24/7 support team via email or live chat so we can investigate this issue and work to get you a resolution to the issue:

https://www.goldenfrog.com/support/

Samuel
Golden Frog Support

@skowly, can you do any other Internet browsing when you are connected with Chameleon? It would be very odd for only Google Voice to stop working.

Thanks,
Michael

Thanks for the quick response and attention to my issue. It is odd… I can browse the web while connected to VyprVPN (Chicago) with Chameleon. When I try to make a call through Google Voice over the VPN, I get the message: “Timed out while joining call. Check your network connectivity and try again.” I accessed the netwebs before and immediately after trying to place the call.

I readdressed the issue and attempted to make a call while connected to another location. I could make the call while connected to Austin, TX with Chameleon, but when I connect to Chicago with Chameleon, the call does not go through.

Hello @skowly,

In testing; while I did not have issues with the Austin Chameleon connection, I was able to recreate the issue with Chicago Chameleon over Google Voice. Tomorrow, I will communicate the issue with our engineers to further determine the issue and investigate.

At your convenience, please e-mail our Support team at support@goldenfrog.com and reference this forum post (subject title ‘RE: Keegan’) so that we can get a ticket going for your issue for our engineers to work with. If we find further information and/or a solution to the issue, we will update this forum post as well.

Thank you!
Keegan
Support Supervisor

Hello @skowly,

I wanted to provide an update for you; we are in the process of investigating the issue with using some Google services over Chameleon connections with a number of US sites. In my testing, Austin does appear to remain unaffected as previously noted. I’ll update this thread when I have further information available.

Thank you,
Keegan

Hello @skowly,

Courtesy of @mikedoug 's research into this issue, we’ve identified the cause and are seeking to have it resolved in an upcoming update. I do not have an ETA, but I will continue to update this post as more information becomes available.

Regards,
Keegan

Hello @skowly,

We released a hotfix update today for the VyprVPN Android app addressing the issue. The cause was in regard to packet sizes over the VPN connection becoming large and causing unstable connections to some web services including Google Voice, Google Play store, and various websites. It should be resolved now in the latest Android release, so at your convenience please update the app to test, and let me know how it goes!

Regards,
Keegan

hello
i have similar problems.
can’t play videos on youtube app both iOS and Android, play store always timed out on Android, can’t sign in to google services on Android, etc.

but the difference is that i have setup the connection on my router. (beta app for tomato firmware here)
connecting via chameleon protocol to US servers

is there any workout for this problem?

Hello Saied!

Sorry to hear that you are having troubles getting Google Services to work on your iOS and Android devices!

First, I would like to ask if you have location services turned on, on either device? If you have your GPS enabled, this could be causing the issues. Also, just to inquire, do you experience this on any other device connected to the router in question? Are you able to view Youtube videos or sign in to Google services on a Mac or PC?

If this issue persists after disabling the location services, please submit a request to us at support@goldenfrog.com so that we can dig a little deeper into this issue that you are seeing!

Thank you for bringing this to our attention!

I tried disabling gps and clearing cash, no success!
with another VPN provider I was able to sign in to google apps on android even with gps enabled!

I tried multiple iOS and Android devices to play videos on YouTube app, sign in to google services on Android; not successful on your servers.

But i have no problem with Google services and YouTube videos when I use handled’s browser (chrome, safari, etcon iOS or Android)
Also I don’t have any problem when I use a mac or pc. And can stream videos from YouTube.
I even used different DNS from Google and comodo, again no success

The major problem is with Google services (sync, Google voice, Gmail, play store, YouTube,etc) on Android devices and some Google apps on iOS devices.

Hey Saied,

I am sorry to hear that you are currently still experiencing issues with Google services on your Android and iOS devices at this time. So that we can better understand and attempt to replicate the issues that you are seeing with these services can you please provide some information and clarification?

First, we see that you stated that you are connecting to our service with our Router Beta Applet for Tomato at this time. Can you tell us if you are connecting to our service using our Android/iOS application as well as the router connection? Or are you only using the router applet connection when seeing this issue?

Also, can you provide us a list of server location that you are having this issue? This information will assist us in an attempt to replicate this issue so that we can take the proper measures in an attempt to locate a resolution.

Thank you for your time and understanding in this issue, and please feel free at any time to supply and information such as application logs and screenshots to support@goldenfrog.com that you think may assist us in resolving this issue faster. Please be sure to reference this Community Forum post to this information for reference.

Cody
Support Team

hey thanks for your reply
i don’t want to make this thread disordered but it may help others as well.
if you think i’m wrong let me know and i will file a thicket with your excellent support team.

when i face these issues, the only active connection is running on router via your applet.
I rather to keep the US IP so i usually use US servers only. tried all of them from US1.vyprvpn.com to US7.vyprvpn.com with different protocols chameleon, 256bit and other except pptp (my ISP) don’t allow it. even connecting to the Austin server didn’t help.

thanks.

Hello Saied,

Thank you very much for that clarification and information on this issue. On attempts to replicate this issue in house we did not show the same results when connecting to our US locations. At this time I would like to attempt to rule out this issue being the connection from the router applet to your mobile devices.

Can you please install our application on your android and iOS devices and with your router disconnected from the VPN attempt a connection directly from our applications on these devices. Once connected please attempt to access these Google services once more and tell us if this issue persist.

Please note that if you may need to disable your Locations Services on your iOS device to access these services:

  • Click on “Settings” > “General” > “Location Services”;
  • Enable the “Location Services” (“ON”);
  • Disable (“OFF”) the “Location Services” for each of the applications featured on the screen that require this service;
  • Return to the menu screen and launch the application of your choice.

Thank you for your time and understanding in this issue!

Cody
Support Staff

hi
sorry for my late respond.
the issue still persists.
i’m getting connection timed out still.
the location is disabled.
can it be related to ping?
i usually get a ping about 300 to 700 when connected to US servers!

thanks

Hello Saied,

Thank you for updating our support team regarding your ongoing issue with various Google services while connected to VyprVPN through the Chameleon protocol method.

Please be aware that our support team has determined that users have the most success accessing Google-based services through our Austin server location. Based on this statement, can you provide our support team an estimated success rate for the services you are attempting to utilize when connected to VyprVPN?

Regarding your question on ping times and how it can effect accessibility to the services, high latency can directly effect both accessibility, consistency, and overall quality for any service used.

Also, I see that in our last correspondence, a support representative requested that you try accessing the services in question with VyprVPN disabled directly on your routing device, and instead use the official VyprVPN application. When attempting this request, did you have the same experience?

Thank you for your continued cooperation with our support team, and we are looking forward to your response!

Jordan
Golden Frog Support

Dear jordan
I think i have answered most of your questions in mey previous posts. However, to clarify:

I tried Austin server and even non US servers and even lowered the encryption by choosing open vpn 160 bit on those servers. No success!

Tried direct connection via isp provided router and used your android app, again no success!

Tried different devices (android), disabled location services, changed DNS, etc

The issue still persists.
But when i tried to connecting to another vpn provider, i was able to download apps from playstore and access Google services,

Thanks again

Saied,

Thank you for that additional information.

At this point we will need to collect more specific and detailed information about your connection issue.

Please do the following and once complete please submit a ticket using the below support link (also please reference this post: Chameleon & Google Voice).

https://www.goldenfrog.com/support/contact



Instructions for running a ping and traceroute in Windows and Mac:


----------WINDOWS OS------------------------

Please open the Command Prompt by pressing the Windows Key + “R” , then in the “Run” box that pops up, type in “cmd” (without quotes) and press Enter. Then the black window for the Command Prompt should come up.

HOW TO RUN A PING TEST:

At the Command Prompt, type in :

ping -n 25 us1.vpn.goldenfrog.com

Copy and paste the results into your reply email.

HOW TO RUN A TRACEROUTE:

At the command prompt, enter:

tracert us1.vpn.goldenfrog.com

Copy and paste the results into your reply email.

--------------MAC OS-----------------------------

HOW TO RUN A PING TEST:
Open your Harddrive.
Open the Applications folder.
Open the Utilities folder.
Double click Terminal.
Then enter: ping -c 25 us1.vpn.goldenfrog.com

HOW TO RUN A TRACEROUTE:
Open your Harddrive.
Open the Applications folder.
Open the Utilities folder.
Double click Terminal.
Then enter: traceroute us1.vpn.goldenfrog.com


Once complete with the ping and traceroute tests, please paste the results into the support form.

Thank you for your time and patience while we continue to investigate the issue.

Regards,

Josh