[China] Extreme Slow speed after 5 miuntes connecting to the servers

The connectivity issues have been fixed in china by the new beta release, So I can actually connect to those 4 recommended servers namely, Hong Kong, Japan, Seattle, France. But After 5 minutes or sometimes even shorter connecting to those Servers the speed drops to like 50KB/s.
This is not just my issue alone. A lot people with Windows, Android and Mac devices are facing the same slow connection issue in China too.
Please fix this problem, It is incredibly frustrating.

Hello @kaldeqca

We’re happy to hear that the beta version allowed you to connect. We’re sorry that you are however experiencing issues with your connection speed. We’d like to take this opportunity to troubleshoot this issue with you. Can you please reach out to our support team at https://www.goldenfrog.com/contact-support

Thank you replying, Well I have contacted the support several times, They have informed me that the issue is a server side one. And it’s still being investigated.

Hello @kaldeqca

Thank you for the update. I’ve reviewed your correspondence with our support queue. At this time, it does look like the extend of the troubleshooting has been done on this. I apologize for any inconvenience this has caused. We are working diligently to have this issues resolved for our customers in China. Please feel free to reach back out to us or our support team if you have any other concerns.

Well actually, currently on the older version of the app (Versions before that 3.10 beta update specifically made for Chinese customers). You are able to connect to only a selective of servers(Around 10 servers but sometimes less) with chameleon protocol. But the speed is undoubtedly good. The connectivity is not the best. Sometimes you may get disconnected from one server and the server won’t answer any pings at the time. But after a little while it popped back up again. So basically the newer version provides better connectivity but the speed is absolutely deplorable, And the older version provides subpar connectivity but the speed is really awesome. So It’s like, pick your poison I guess XD.

Anyway jokes aside I think the slow speed issue on the newer version could be something related to the changes made to the chameleon protocol that made it easier to be detected. Because the speed when connected to server right away is good but it drops insanely after a few minutes. Also You can’t manually choose ports for chameleon protocols on the new beta version, On the older version you have to manually choose ports for the chameleon protocol in order it to work. Overall I really think this issue needs to be addressed quickly, It has been over 4 weeks now.

Best Wishes

Hello @kaldeqca

Sorry to hear you are experiencing slow speeds. I would like to have you try the troubleshooting steps at the following link: https://support.goldenfrog.com/hc/en-us/articles/360005018231-Troubleshooting-slow-speeds

If you need any further assistance, please contact our support team at https://support.goldenfrog.com/


I lived in China for almost 4 years and I saw the same problem. Is was NOT the VPN application, it was the Chinese Internet Provider. I had to reset my Router that was connected to the Internet Provider. I had both China Unicom and China Telecom.


Did you fix it? @Jim_Hagerman

Sometimes I had to shutoff the main external router and then turn back on after 30 seconds. Sometimes I would have to do that several times a day. I connected their router to a power strip to make it easy.

And It solves the slow speed issues? @Jim_Hagerman

Yes it solved the slow connection in both Baoding and Shanghai. But, depending on when, sometimes this had to be done several times a day and sometimes several times an hour. If I did not run VPN it was fine. They detect the VPN connection.

Thank you very much sir, I’ll try it.

It didn’t work for me, My connection still gets really slow after like 2 minutes, Can you please elaborate on how did you reset the router. @Jim_Hagerman

What I did was logout of VPN on all devices connected. Then physically turn off all routers that connect to the Telecom servers. Mine was in the wall behind a panel. I wired the power outside so I could reset the router. Also turn off my router.

Are you on the new beta version? I have tried disconnecting the router for 30 seconds then turn it on, It didn’t work, I still get extremely slow speed after 2 minutes connecting to the vypr servers, Do you have a discord account that I can add? @Jim_Hagerman

I’m no longer living in China. I lost my job because I have a US passport even though I live in Germany. This fixed my connection in the past. But, China may be more strict now. I left China the end of September.

I see, they’re way more strict now. I don’t think this method can solve the current issue, Thanks for the information though. Appreciated it.