Connection button on MAC does not work?

Hi there,

I have used Vyprvpn for a while without problems, but since approximately last week nothing happens when clicking the connection button. Literally nothing happens. The same happens with my girlfriend’s MacBook. Who knows how to solve this issue?

Hello!

I understand that when you click ‘connect’ on your Vyprvpn application on your Mac nothing happens.

Please try the following steps to reset the Vyprvpn service and see if the issue persists:

  1. Quit that VyprVPN application from the ‘Quit’ option in the VyprVPN menu at the top of your screen.
  2. To remove the service, use Command+Tab and select Finder, then press Command + Shift + G to bring up the Go To window and type in: /Library/PrivilegedHelperTools
    A window should open showing the VyprVPNService sitting there. Drag it to trash.
  3. Then you will need to log out of OS X and log back in to complete service removal.
  4. Empty the trash bin.
  5. Restart VyprVPN to prompt the reinstallation of the VyprVPNService.

If you have further assistance, please contact Golden Frog support - https://www.goldenfrog.website/contact-support

Regards

I have the same problem.
All the above-mentioned solution steps did not lead to any success. I notice that on my iMac (connected to LAN) I have no problems after standby, but on my MacBook (connected to WiFi) I cannot connect to a server after each standby.
To establish a VPN connection, I have to shut down the MacBook every time.
Regards

Hello!

I understand. To properly assist you with your connection issue, please email our support team directly at support@goldenfrog.com

Regards,

Technical support

now VyprVPN is working fine on OSX and iOS since 10 days.:smiley:

Try resetting your Vyprypn service to solve your connection problems. This process works on my mac and maybe this will help you. Just quit the Vyprypn application and remove the service. After that, you need to log in and delete everything on the trash bin, then restart the application. I hope this works on your mac.

Identical issue. Followed your trouble shooting tips and doesn’t work. Vypr works on every other device except macbook pro. Works fine on my Windows 10 laptop, ios and android devices.

Hello @nowbeehave

Sorry to hear that you are having issues with the connect button not responding and that the troubleshooting steps did not work. Please contact our support team directly at https://www.goldenfrog.website/support/ so we investigate this further for you.

Thanks!

I’m having the same problem and reseting the service didn’t work. I figured out that if I go to the Network settings in System Preferences and enter a bunch of different servers manually, eventually it will connect to a random one that works. The actual Vypr program will sometimes still say disconnected even as it’s working though. Anyone have any idea whats going on?

Hello @andrewsanglau!

If you find you are still having this trouble after resetting the service, please use these steps to verify that the extension required for VyprVPN is not being blocked:

Click on the Apple icon menu > system preferences > Security & Privacy > General tab.
With the Security and Privacy window still open, attempt to connect the VPN with Chameleon or OpenVPN.
On the Security and Privacy screen do you now see “System software from developer “Golden Frog” was blocked from loading”. ?
If so, click Allow the connection.
Quit VyprVPN and relaunch it. (Right click on the VyprVPN icon on your dock and select Quit)

Thanks!

this doesn’t help.
the last reply of this post gave the reason and solution
https://forum.goldenfrog.com/t/vypr-vpn-mac/4326/12

vyprvpn mac app uses api.goldenfrog.com to get ips of the servers.
if it fails to connet api.goldenfrog.com, the connect button don’t work.
the solution is as follows:
step 1: the iOS version works well. so you just open it and connect.
step 2:on the setting, look at the log. the log reads that it use IKEv2 vpn and you can see the ip.
step 3:on your mac, open System Preference -> Nextwok.
add an IKEv2 vpn config manually
step 4:the RemoteID is *vyprvpn.com, authenticate by your vyprvpn username and password.then you can connect.

the ip won’t work for a long time.when connection fails, do step 1-3 again with a new ip.

hope the support team can fix this soon. make the mac app work like the iOS app does may help.

see my reply for solution

please look at this post to see the solution and hope u can fix it soon