[Daily Update] Current VyprVPN status in China

Started at 23 of November. There have been a lot of connection issues within China. Many people are still facing those connection issue currently. So I decided to make a thread about it. I’ll keep updating this thread daily Until the connection issue is fully fixed.
Here’s the timeline
September 23th the VyprVPN service was blocked completely.

October 3th There was a beta version(3.1.0.10116) released, It did allow people to establish connections to the servers. Only a few servers actually show pings
image
But you can actually connect to the servers that don’t response to pings
For example I can connect the “Seattle” server despite it not showing any pings

But after connected to the server, the connection speed becomes extremely slow after like 3 to 5 minutes of use. The reason behind it should be that the connection it established on the new beta version is detectable by the GFW and can be throttled after a few minutes. Which is extremely frustrating.
Here’s the speed when I connect to the server right away
image


And here’s the speed when I connected to the server after only 3 minutes and 30 seconds
image

The download speed becomes completely unusable.
I have to disconnect and reconnect to the server for each 3 minutes in order to get an usable speed.
That is completely unacceptable.
The worst part is the issue has been persisting for one and a half months now, There have been some updates like 3.1.010133, but none of these updates solve the slow speed issue.

Currently I can use the older version(2.16.4.9212) to establish connections with decent speed.On the older version I can only connect the servers that show pings, It usually has around 5 to 10 servers that do response to pings. But the connections on the older version are really unstable. Usually after 30 to 1 hour The connection would be lost and the server not response to pings requests, So I have to constantly switch servers.

This is issue has been persisting for such a long time now. I really think the tech team should fix it right away. But before that I’ll update my daily experiences here.

November 15th 2019 Slow connection speed after a few minutes on the new version and unstable connection on the old version.

November 16th 2019 Same situation Slow speed after a few minutes on the new version
And here are the servers that response to pings requests on the older version at the time I’m testing


November 17th 2019 still same situation today, unstable connection on the older version, speed dropping on the newer version.

November 18th 2019 still same situation today, unstable connection on the older version, speed dropping on the newer version. today only 5 servers are available.

November 19th 2019 still same situation today, unstable connection on the older version, speed dropping on the newer version.

November 20th 2019 still same situation today, unstable connection on the older version, speed dropping on the newer version.

November 21th 2019 I think the situation is partially resolved on the older version of the app, Currently there is no speed dropping nor unstable connections, But only a part of the servers that work but they always can show pings now.

November 22th 2019 same situation as yesterday, speed drops after exactly 1.4 minutes after connected to the server, but connection on the older version is good and really stable now.

November 23th 2019 same situation as yesterday, speed drops after exactly 1.4 minutes after connected to the server on the newer version, but connection on the older version is good and really stable.

November 24th 2019 same situation as yesterday, speed drops after exactly 1.4 minutes after connected to the server on the newer version, but connection on the older version is good and really stable.

November 25th 2019 same situation as yesterday, speed drops after exactly 1.4 minutes after connected to the server on the newer version, but connection became unstable again.

November 26th 2019 same situation as yesterday, speed drops after a few minutes of connected to the server on the newer version, and unstable connection on the older version, The service is still unusable, This is extremely disappointing.

November 27th 2019 same situation as yesterday, speed drops, but it doesn’t seems like the speed drop is related to the time, but actually related to the data, After I downloaded around 50mb data then speed starts to drop. I don’t what cause this but currently the new version is still unusable to me, On older version the connection speed is good but it has become unstable again. really disappointing performance.

November 28th 2019 same situation as yesterday, speed drops on the newer version, and unstable connection on the older version, this has been extremely disappointing now. I really wish they can find a solution for this issue.

November 29th 2019 same situation as yesterday, speed drops on the newer version, and unstable connection on the older version, this has been extremely disappointing now. I really wish they can find a solution for this issue.

November 30th 2019 today on the new version, the speed doesn’t drop gradually now, but now it just dropped abruptly to a point that the connection speed is almost non-existent. it’s like around 2kb/s or even lower, this is really frustrating consider that the problem has been occurring for over 2 months now on the new version.
On the older version only a handful of servers are connectable and the connections are unstable.

December 1st 2019 still the same old problem, I received a response that a new version will be released in the near future that aims to solve this speed drops issue, But the release date is TBD.

December 2nd 2019 still the same old problem on the new version, but on the older version one connection last 2 hours with good speed. I think the situation is getting better now.

December 3rd 2019 still the same old problem on the new version. and unstable connection on the older version.

December 4th 2019 still the same old problem on the new version. and unstable connection on the older version.

December 5th 2019 unable to connect to any server both on the older version and newer version.

December 6th 2019 None of the servers response to pings today on the older version at the time I’m testing, and on the newer version, I still face speed drops issues.

December 7th 2019 only 3 servers response to pings today on the older version at the time I’m testing, and on the newer version, I still face speed drops issues.

December 8th 2019 only 4 servers response to pigs today on the older version at the time I’m testing.
image
This is completely unacceptable now

December 9th 2019 still the same situation. This has been over 2 months now. it’s completely unacceptable now.

December 10th 2019 still the same situation.

December 11th 2019 still the same situation.

December 12th 2019 still the same situation.

December 13th 2019 still the same situation. I heard from a comment below, that the version 3.0.0.9646 functions better, I’ll try to test it later or tomorrow.

December 14th 2019 the things are looking better on the older version, there are a lot servers are working today at the time I’m testing

December 15th 2019 Connection is stable on the older version, But there are only 11 servers that are constantly working.

December 16th 2019 connection is stable on the older version today. 11 servers are working.

December 17th 2019 connections became unstable on the older version again, and there are less servers that can response to pings at the time I’m testing.
I have asked again for the release date of the new version which aims to address the current issues. But still I did not get any info regarding the release date, This has been quite unacceptable.

December 18th 2019 connections became stable again on the older version, there are 11 servers working at the time I’m testing.

December 19th 2019 connections on the older version once again has become unstable and there are only 3 servers are working.

December 20th 2019 connections on the older version is still unstable. This is getting really frustrating.

December 21th 2019 connections on the older version is still unstable. There are only 5 servers working at the time I’m testing.

December 22th 2019 connections on the older version is still unstable. There are only 3 servers working at the time I’m testing.

December 23th 2019 connections on the older version is still unstable. There is only 1 server working at the time I’m testing.

December 24th 2019 connections on the older version is still unstable. There are only 2 servers working at the time I’m testing.

December 25th 2019 connections on the older version is still unstable. There are only 6 servers working at the time I’m testing. Also today is Christmas day, So Have an awesome Christmas day to everyone.

December 26th 2019 connections on the older version is still unstable. There are only 2 servers working at the time I’m testing.

December 27th 2019 connections on the older version is still unstable. There are only 3 servers working on the older version at the time I’m testing.

December 28th 2019 connections on the older version is still unstable. There are only 6 servers working on the older version at the time I’m testing.

December 29th 2019 connections on the older version is still unstable. There are only 3 servers working on the older version at the time I’m testing.

December 30th 2019 connections on the older version is still unstable. There are only 2 servers working on the older version at the time I’m testing.

December 31th 2019 connections on the older version is still unstable. There are only 2 servers working on the older version at the time I’m testing.

January 1st 2020 connections on the older version is still unstable. There are only 2 servers working on the older version at the time I’m testing.

January 2nd 2020 connections on the older version is still unstable. There are only 3 servers working on the older version at the time I’m testing.

January 3rd 2020 connections on the older version is still unstable. There are only 7 servers working on the older version at the time I’m testing.

January 4th 2020 connections on the older version is still unstable. There are only 2 servers working on the older version at the time I’m testing.

January 5th 2020 connections on the older version is still unstable. There are only 5 servers working on the older version at the time I’m testing.

January 6th 2020 connections on the older version is still unstable. There is only 1 server working on the older version at the time I’m testing.

January 7th 2020 connections on the older version is still unstable. There are only 2 servers working on the older version at the time I’m testing.

January 8th 2020 connections on the older version is still unstable. There are only 2 servers working on the older version at the time I’m testing.

January 9th 2020 connections on the older version is still unstable. There are only 2 servers working on the older version at the time I’m testing.

January 10th 2020 connections on the older version is still unstable.On the older version No servers are working at the time I’m testing

January 11th 2020 connections on the older version is still unstable. There are only 3 servers working on the older version at the time I’m testing.

January 12th 2020 connections on the older version is still unstable.On the older version No servers are working at the time I’m testing

Well by this opportunity I’d like to clear a few things up regarding each version on the PC

Version 3.0.0.9646: Currently. From the official release site here https://www.vyprvpn.com/vpn-apps/vpn-for-windows You’ll receive the latest stable version of app which is 3.0.0.9646. This version does not include the newly updated chameleon 2.0. You only can connect to the servers that response to pings requests on this version. But the speed does not drop on this older version.

Version 2.16.4.9212: This also is the an older version of the app, It functions the same as the 3.0.0.9646. But it has a speed graph which I use. No speed drops on this one either, but can only connect to servers that response to ping

Version 3.1.0.10116: This is what they call the beta version that is designed to solve connectivity issue in China, It allows to connect to any servers even the servers that do not response to ping requests. But the speed drops drastically after a few minutes of use. You can get this version from their status page here https://support.goldenfrog.com/hc/en-us/articles/360009427492

Version 3.1.0.10143: This is an updated version based on the beta release of 3.1.0.10116 it functions exactly the same as 3.1.0.10116 which means it did not solve the throttled speed issue.

Version 3.1.10133: This is the newest beta version based on the 3.1.0.10116 version, It did not solve anything either. Also This version number might be incorrect Since I have to constantly switch app version from the newest to older ones.

Also I’d like to clear the difference between chameleon 1.0 and 2.0

Chameleon 1.0 This protocol is used on the version 3.0.0.9646 and below it allows you to customize your protocol ports and it does not have speed dropping issues and you only can connect to the servers that response to ping requests, In the past It functions really well but now only 5-10 servers would show pings which means you only can connect to those servers, and each connection would last at around 30 to 60 minutes less or more. After that time, The connection would be be lost and the server you connected to would not response to pings requests, You have to switch to another server, but after a while that server you got disconnected from would actually response to ping again. So you have to constantly switch between servers which is quite annoying and bothersome. But at least it provides an usable experience currently

Chameleon 2.0 This is the newly upgraded protocol that is on the new beta versions 3.1.0.10116 and above. it aims to solve the connectivity issue in China specifically. It has a few servers that response to pings requests but It doesn’t matter you can connect to servers that do not response to pings, which means you can connect to most of the servers. Currently the connection this new protocol established is detectable by the GFW, and it will be throttled after around 3 to 5 minutes, The speed will become like 50kb/s sometime even less than that. You have to disconnect and reconnect each 5 minutes which is completely unusable.
Well sometimes the connection could last a long time with good speed on this version But The situation like that is extremely rare and random I really don’t know how to make this occur, Last week’s Saturday I connected to the server Japan on the new beta version and the connection speed was good and most amazingly it actually lasted for a day. But at Sunday everything just went back again, I got speed drops after 5 minutes.
Anyway I hope that clears up the situation here.

3 Likes

I agree. I am using the Mac app (version 3.1.0.7459). Everyday, only a few servers show ping, and I can only connect to a few servers. The speeds won’t drop dramatically after a while, but the connections to some servers aren’t very fast in the first place. Austin and UK have been working the past few days, but they don’t seem to be very fast. Taiwan tends to be one of the fastest, but it seldomly works over Chameleon.

Edit: However, today, more servers are working than usual. Taiwan and seattle are currently working for me.

@kaldeqca A very comprehensive analysis, thank you for sharing this. Though, I wish the speed was better for you and our client base, this info is a excellent example of front-line sampling.

Looking forward to your updates on this thread!

Appreciated it, Hope this can be an use for the tech team.

Are you able to customize ports with the chameleon protocol? I don’t know too much about the mac version But on Windows If you are NOT able to select ports for the chameleon protocol that probably means You’re using the newly updated chameleon 2.0, If you ARE able to select ports for the chameleon protocol then that means you’re using the 1.0

Currently on 2.0 the speed drops after a few minutes, but all servers should be available to connect(Only some of them show pings but all of them should be connectable)

On the 1.0 however the speed doesn’t drop. But only a few servers are connectable which are the servers that can actually show pings. but the connection is really unstable most of the time, Usually each connection can last 30 - 60 minutes, after that, the server would just not response to ping and you need to switch another server so on and repeat.

edit: Okay I realized that you’re probably using the old version since on MAC the version 3.1.0 is actually updated on the august. but on the PC the beta version 3.1.0 is actually updated on the October which comes with the new experimental chameleon protocol 2.0 .(I know it’s Pretty confusing whoever did that should made it more clear)

Yes, 3.1.0 for Mac is the current stable version and allows me to customize ports. I tried 3.2.0, which is the beta, about two weeks ago. It did not allow me to choose ports. When I tried 3.2.0, it worked worse than 3.1.0, so I switched back. However, I know the beta version for Mac has been updated about a week ago, but I haven’t tried it yet, so I don’t know how well it works.

Can you please elaborate on how did it work worse? Did it have less connectable servers or did it have slow speeds, Also there have been several updates on the beta version for both Mac and PC but those updates didn’t solve any issues.

When I tried it, Chicago was the only working server. None of the other servers I tried worked.

did you experience the speed drop issue as well?

For me, speed drops don’t occur on a regular basis and are not that extreme.

In the first few days of the beta release, there was not speed issue, but now it certainly does.

How did you find out that there were two distinct versions of the chameleon protocol?

I usually distinguish it by looking at the chameleon protocol, If the chameleon protocol do not let you select ports then it should be the newer version, If it does the it should be the older version.

I can personally testify that the experience kaldeqca has chronicled in the OP is completely accurate. My own experiences using VyprVPN (newest version only) in China are a mirror of theirs.

Thanks for doing this!

Thanks for confirming it, Currently from what I’ve heard that there will be a new version releasing the in near future to address this issue that I posted.

Are you have trouble connecting to most US servers?

I do have troubles connecting to most of the vypr servers.

Recent signup,

I’m finding connecting with Vypr to be nearly impossible within China.

There is a new version on the horizon that aims to solve issues in China.

我现在使用的是3.0.0.9646版本
连接部分服务器有可能会保持超长时间不断线、
目前最高保持过超过二十四个小时

现在我正在连接中的台湾服务器也保持了七个小时,网速也还可以。