FAQ and Install instructions- VyprVPN Linux CLI

Frequently Asked Questions

How do I install and connect to the CLI?

  1. Download the install package for your architecture (64-bit or 32-bit)
    a. 32-bit: vyprvpn-linux-cli-XXXXXXXX.deb
    b. 64-bit: vyprvpn-linux-cli-XXXXXX.deb
  2. Install the package by using the GUI or GDebi.
  3. Log in to the command line interface (CLI) by entering the following in command line: “vyprvpn login
  4. Enter your username and password.
  5. (Optional) To see the server and protocol that will be used to connect by default enter: “vyprvpn server show” or “vyprvpn protocol show”.
  6. Connect by entering: “vyprvpn connect
  7. (Optional) Change the server by entering: “vyprvpn server set”, then enter the server number from the server list.
  8. (Optional) Change the protocol by entering: “vyprvpn protocol set”, then enter the protocol number from the server list.

How do I show what server and protocol I am connected to?

vyprvpn server show or vyprvpn protocol show

How do I list the available protocols?

vyprvpn protocol list

How do I list the available servers?

vyprvpn server list

How do I log out and log in?

vyprvpn login or vyprvpn logout

How do I update my password?

To change your password use the Golden Frog Control Panel. To synchronize your new password, log out of the VyprVPN service then log in.

How do I know my password is incorrect?

You will receive an authentication error during your login attempt.

How do I refresh my server list?

If you would like to see if there is a new server available, you can enter the command: vyprvpn refresh

Hi i try test version vyprvpn-linux-cli-0.0.1-55.amd64.deb on slackware 14.1 x64 (latest one)
i unpack deb package i put into right folders etc.

All stuff run - i can execute ,but i have problem with connection i just get message - can`t connect :frowning:

there is possibilities to fix that ?
many corpo use SLackware and i also use unRAID which based on slackware 14.1 (x64)

I hope Goldenfrog can make more universal binaries.
I remeber when i using Hamachi (`this is also some kind of VPN) they also used pre-compiled binaries but works almost on any systems (ubuntu, slackware, mint, redhat etc)

Hello,

I am sorry to hear that you are unable to connect to the VPN with our VyprVPN CLI on your slackware operating system. Please note that the VyprVPN CLI has only been tested on Ubuntu and Mint operating systems.

I see that you have submitted a support ticket for this issue already and that our support team is currently working with you via your support ticket #425489 through email. We will continue to troubleshoot your issue via your support ticket.

Thank you for patience and cooperation in this matter!

Hi any news in topic ? maybe some new beta ?

i was try once more again run version 0.0.1-55 on slackware

but when i run bin vyprvpn - im immediately get “Login failed!” less in one second :confused:
and im sure login and password which i used are OK

@piotrasd I am sorry to hear that you are still unable to connect to the VPN using the VyprVPN CLI. As we didn’t hear back from you after multiple attempts to reach out to you in your support ticket, we closed the support ticket believing you no longer needed assistance. At this time, I have created you a follow-up support ticket (#455245). Please look for this support ticket and my request for logs, along with additional information, in your email shortly. Once we hear back from you by responding to your support ticket then we will continue troubleshooting your issue.

We appreciate your patience and cooperation in this matter.

You guys should say Debian support instead of Linux support. It would be really nice if you can package it in .rpm or even a tarball so everyone who has Linux can run VyprVPN.

Installed the CLI using the amd64 deb for Mint, and have come up against a few problems.

When I use the login option, I get Login result: 500: and when I use the ‘connect’ option, I get the following:

 Missing login details, please enter them now
    Username: xxx@yyy.com
    Password: 
    panic: runtime error: index out of range
    
    goroutine 16 [running]:
    runtime.panic(0x6eb400, 0x8d9b9c)
    	/goroot/src/pkg/runtime/panic.c:279 +0xf5
    main.getDefaultServer(0x0, 0x0, 0x0, 0x0, 0x0, 0x0)
    	/buildroot/vyprvpn.go:454 +0x25b
    main.getServer(0x0, 0x0, 0x0, 0x0, 0x0, 0x0)
    	/buildroot/vyprvpn.go:432 +0x12c
    main.getServerInfo(0xc208042210, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0)
    	/buildroot/vyprvpn.go:408 +0x315
    main.procConnect(0xc208042210)
    	/buildroot/vyprvpn.go:223 +0x43
    github.com/codegangsta/cli.Command.Run(0x72d110, 0x7, 0x72cbb0, 0x1, 0x72d110, 0x7, 0x7c6030, 0x6d, 0x0, 0x0, ...)
    	/gopath/src/github.com/codegangsta/cli/command.go:101 +0xc6f
    github.com/codegangsta/cli.(*App).Run(0xc2080540c0, 0xc20800e000, 0x2, 0x2, 0x0, 0x0)
    	/gopath/src/github.com/codegangsta/cli/app.go:125 +0x941
    main.main()
    	/buildroot/vyprvpn.go:156 +0x525
    
    goroutine 19 [finalizer wait]:
    runtime.park(0x419660, 0x8ddbb0, 0x8dbe49)
    	/goroot/src/pkg/runtime/proc.c:1369 +0x89
    runtime.parkunlock(0x8ddbb0, 0x8dbe49)
    	/goroot/src/pkg/runtime/proc.c:1385 +0x3b
    runfinq()
    	/goroot/src/pkg/runtime/mgc0.c:2644 +0xcf
    runtime.goexit()
    	/goroot/src/pkg/runtime/proc.c:1445
    
    goroutine 20 [syscall]:
    os/signal.loop()
    	/goroot/src/pkg/os/signal/signal_unix.go:21 +0x1e
    created by os/signal.init·1
    	/goroot/src/pkg/os/signal/signal_unix.go:27 +0x32
    
    goroutine 23 [select]:
    net/http.(*persistConn).readLoop(0xc2080422c0)
    	/goroot/src/pkg/net/http/transport.go:868 +0x829
    created by net/http.(*Transport).dialConn
    	/goroot/src/pkg/net/http/transport.go:600 +0x93f
    
    goroutine 24 [select]:
    net/http.(*persistConn).writeLoop(0xc2080422c0)
    	/goroot/src/pkg/net/http/transport.go:885 +0x38f
    created by net/http.(*Transport).dialConn
    	/goroot/src/pkg/net/http/transport.go:601 +0x957
    
    goroutine 27 [runnable]:
    net/http.(*persistConn).readLoop(0xc208042580)
    	/goroot/src/pkg/net/http/transport.go:868 +0x829
    created by net/http.(*Transport).dialConn
    	/goroot/src/pkg/net/http/transport.go:600 +0x93f
    
    goroutine 28 [select]:
    net/http.(*persistConn).writeLoop(0xc208042580)
    	/goroot/src/pkg/net/http/transport.go:885 +0x38f
    created by net/http.(*Transport).dialConn
    	/goroot/src/pkg/net/http/transport.go:601 +0x957

Any thoughts?

@durandal Thank you for the output info. I believe I have seen similar output testing on Xubuntu when trying to connect without being logged in. However, I don’t have that distro available immediately for testing to confirm.

While straight-forward, can you provide step-by-step actions to replicate this behavior?

I suspect the process you followed was:

  1. Enter command: vyprvpn login
  2. Enter username
  3. Enter password
  4. Error appears - “Login result: 500:”

Is that accurate?

Have you tested VyprVPN CLI on any other Linux machines/distros? Any similar issues there, or just on this machine? Are you experiencing login issues on any other devices running the VyprVPN application?

Thank you in advance for this information. I have notified our development team so that they can weigh in if necessary and review the command line output you posted.

Nick
Golden Frog Support

That’s correct. The long ‘panic’ error was the result of vyprvpn connect, with the same credentials.

I’ve only tested with this machine, but I am having some login issues with android.

The login issue has been fixed, so it looks like it was something unrelated to the app. Might be worth an update to try and catch the ‘connect without login’ bug, however!

@durandal I am glad to hear you are able to log in now! Please let me know if it happens again. This post has been brought to the attention of the development team and they will further investigate the command line output you posted.

Nick
Golden Frog Support

hi there

same here with Fedora 21 i copied everything from .deb in respective places and i get Login failed!

would be nice in my opinion if this could be more verbose as to what is actually causing the failed login attempt… it’s easier to troubleshoot too.

too bad though… i just bought the subscription and now it doesn’t work (yet)

Hello dhbiker!

Sorry to hear you are having issues getting logged in to VyprCLI!

There are of course many reasons that you could be experiencing this error, and unfortunately in the CLI’s current iteration, we do not have more verbose error reporting. Just as a preliminary measure, can you attempt to establish a connection manually via Network Manager using the instructions in the link below (these instructions are also for Ubuntu, so adjustments will need to be made):

https://www.goldenfrog.com/support/vyprvpn/vpn-setup/linux/openvpn

Also, please keep in mind that we have only tested this application on Debian bases distro’s such as Mint and Ubuntu. If possible, please submit a support request to us at support@goldenfrog.com so that we can investigate this issue that you are seeing, and see if the app can be made to work on Fedora.

Steven
Golden Frog Support

i figured out a bit how your client works… gotten around to login and now i get this

Error: Received status 400 from VyprVPN management service. Server connect request failed

but we can continue via mail too

Hello I could connect/disconnect despite the 400 Error, with this procedure:

// login & server selection alredy done //

// conencting with pptp //

gio@ME:~$ vyprvpn protocol set pptp

Success: pptp set as new default

gio@ME:~$ vyprvpn connect

Error: Received status 400 from VyprVPN management service. Server connect request failed // here is Error //

gio@ME:~$ nmcli con up id VyprVPN // invoke NM //

Active connection state: unknown

Active connection path: /org/freedesktop/NetworkManager/ActiveConnection/1

state: VPN connecting (need authentication) (2)

state: VPN connecting (3)

state: VPN connecting (getting IP configuration) (4)

connection activated

// let’s disconnect//

gio@ME:~$ nmcli con down id VyprVPN

gio@ME:~$ vyprvpn disconnect

Success! 400: Server disconnect request failed

Is there ever a chance we’ll see an RPM package for Fedora/CentOS? 2nd most popular package management flavor really needs to be represented with a binary. I tried to port the .deb to RPM using Alien, but it fails at install.

@MssngPrsn We are currently reviewing other distros and definitely want to expand the release scope of VyprVPN CLI in the future. I cannot offer an ETA, but can tell you we are considering Fedora and CentOS.

If you’d like, you can submit your idea for review on our Ideas page. There is an existing entry here for Fedora if you wish to cast your vote!

Nick
Golden Frog Support

Hey

Getting “Error: Received status 400 from VyprVPN management service. Server connect request failed” when running “vyprvpn c”, tried all protocols. Running a clean install of ubuntu 14.04.1.

Syslog reports following “NetworkManager[747]: Unmanaged Device found; state CONNECTED forced. (see http://bugs.launchpad.net/bugs/191889)”

Havent done anything really to find a solution yet, do you have any suggestions for me.

Thanx…

Hello jsoprano10,

As I understand you are currently unable to establish a connection due to the following error: Status 400.

Please attempt to resolve the issue by following these steps:

  1. Navigate to your NetworkManager.conf file at the following location: ~/etc/NetworkManager/NetworkManager.conf
  2. Edit the following text:
    [ifupdown]
    managed=false
    -to-
    [ifupdown]
    managed=true
  3. Once the edit is made and saved, then run the following commands: ‘service networking restart’ & ‘service network-manager restart’
  4. Launch VyprVPN CLI and attempt a connection

Please notify our support team of your results after attempting the steps provided.

Best Regards,
Jordan

Great Jordan… Now got “Success! VyprVPN Connected”…
Nice and easy fix. Thanx