FAQ and Install instructions- VyprVPN Linux CLI

i figured out a bit how your client works… gotten around to login and now i get this

Error: Received status 400 from VyprVPN management service. Server connect request failed

but we can continue via mail too

Hello I could connect/disconnect despite the 400 Error, with this procedure:

// login & server selection alredy done //

// conencting with pptp //

gio@ME:~$ vyprvpn protocol set pptp

Success: pptp set as new default

gio@ME:~$ vyprvpn connect

Error: Received status 400 from VyprVPN management service. Server connect request failed // here is Error //

gio@ME:~$ nmcli con up id VyprVPN // invoke NM //

Active connection state: unknown

Active connection path: /org/freedesktop/NetworkManager/ActiveConnection/1

state: VPN connecting (need authentication) (2)

state: VPN connecting (3)

state: VPN connecting (getting IP configuration) (4)

connection activated

// let’s disconnect//

gio@ME:~$ nmcli con down id VyprVPN

gio@ME:~$ vyprvpn disconnect

Success! 400: Server disconnect request failed

Is there ever a chance we’ll see an RPM package for Fedora/CentOS? 2nd most popular package management flavor really needs to be represented with a binary. I tried to port the .deb to RPM using Alien, but it fails at install.

@MssngPrsn We are currently reviewing other distros and definitely want to expand the release scope of VyprVPN CLI in the future. I cannot offer an ETA, but can tell you we are considering Fedora and CentOS.

If you’d like, you can submit your idea for review on our Ideas page. There is an existing entry here for Fedora if you wish to cast your vote!

Nick
Golden Frog Support

Hey

Getting “Error: Received status 400 from VyprVPN management service. Server connect request failed” when running “vyprvpn c”, tried all protocols. Running a clean install of ubuntu 14.04.1.

Syslog reports following “NetworkManager[747]: Unmanaged Device found; state CONNECTED forced. (see http://bugs.launchpad.net/bugs/191889)”

Havent done anything really to find a solution yet, do you have any suggestions for me.

Thanx…

Hello jsoprano10,

As I understand you are currently unable to establish a connection due to the following error: Status 400.

Please attempt to resolve the issue by following these steps:

  1. Navigate to your NetworkManager.conf file at the following location: ~/etc/NetworkManager/NetworkManager.conf
  2. Edit the following text:
    [ifupdown]
    managed=false
    -to-
    [ifupdown]
    managed=true
  3. Once the edit is made and saved, then run the following commands: ‘service networking restart’ & ‘service network-manager restart’
  4. Launch VyprVPN CLI and attempt a connection

Please notify our support team of your results after attempting the steps provided.

Best Regards,
Jordan

Great Jordan… Now got “Success! VyprVPN Connected”…
Nice and easy fix. Thanx

Excellent! We are pleased to hear that our suggestion has presented you with a resolution. If you have any further feedback regarding VyprVPN CLI, please let us know.

Best Regards,
Jordan

You have made a great package and solution for vypr on my ubuntu servers. Been looking for something like this a long time, finally something that works without hassel. Im running vyprvpn -c on boot, and it connects every time.

Are there anyway I can check status and uptime from CLI ? I am using “curl -s checkip.dyndns.org | sed -e ‘s/.Current IP Address: //’ -e 's/<.$//’” to check my ip, and of course “ifconfig”. But wondering if there is something else I can use ?

Thanks in advance.

Just create a tarball for Linux. We all can package it for our respective distrobutions…

Not working with Ubuntu 15.04. Can someone take a look at that? It works with 14.10 and there can’t be that much of a difference. I just get “Login Failed!”, immediately after attempting login.

Hello @mfaine,

I am sorry to hear that you are seeing an authentication issue at this time, we have someone contact you directly via email to determine if this is an account or service related issue.

Thank you for reaching out!

Cody
Golden Frog Support

@mfaine, Can you run the following commands in terminal for me?

service vyprvpn restart
service vyprvpn status
vyprvpn login

If you encounter any errors, please let me know what they are. Our dev team is looking into this presently. Thank you!

Nick
Golden Frog Support

@nick ,

I’ve been working on this a bit more and installing and removing the package causes the following message:

Preparing to unpack vyprvpn-linux-cli-0.0.1-55.amd64.deb …
Unpacking vyprvpn (0.0.1-55) …
Setting up vyprvpn (0.0.1-55) …
start: Unable to connect to Upstart: Failed to connect to socket /com/ubuntu/upstart: Connection refused
dpkg: error processing package vyprvpn (–install):
subprocess installed post-installation script returned error exit status 1
Processing triggers for ureadahead (0.100.0-19) …
Processing triggers for systemd (219-7ubuntu4) …
Errors were encountered while processing:
vyprvpn

To get around this I used this process: https://www.nesono.com/node/368 (be sure to read the comments)

However, after purging openvpn and reinstalling it, and after purging vyprvpn, openvpn connections directly from network manager work just fine. I can’t seem to get the vyprvpn package to install though, I get the message above and working around it with the process in the link above will get it installed but is probably why it wasn’t working in the first place.

@mfaine Thank you for the update.

I will pass along your findings to our dev team here for further investigation. In the meantime, I would recommend connecting via the network manager setup for OpenVPN.

Stay tuned!

Nick
Golden Frog Support

@nick Thank you! I will.

@mfaine

Thanks very much for bringing this issue to our attention. The information that you provided is really helpful. As you pointed out, the vyprvpn cli installation is failing when executing the post-install script from our package. The contents of the post-install script are pretty straightforward: start vyprvpn.

I tried to reproduce this issue on a 15.04 vm but unfortunately was not able to - the package installed fine and the vyprvpn service was started without any problems. So I researched the error message that you provided. It looks like a few other third-party apps have experienced this same issue with their packages on 15.04. One of the bigger changes in 15.04 apparently is the change from using upstart to systemd. systemd is supposed to be backwards-compatible with upstart, meaning that the start vyprvpn command should have been able to start the vyprvpn service. However it appears that in certain cases these upstart commands are not being correctly handled.

Currently our vyprvpn cli package is only supported for 14.04, so for now, we’re going to wait and see if this issue is corrected in a newer build of 15.04. If not, we’ll have to put a workaround in our package, to start the vyprvpn service with an alternate command on 15.04.

Anyway thanks very much for letting us know, that’s a great heads up for us, and sorry that you are having to use a workaround on 15.04.

Please let us know if you have any more questions or input.

Thanks,
Katie

i use vyprvpn in a terminal, i have enter my username and my password and then i got this message : Login result: 401: Not authorized

I’m afraid I don’t show an account under your forum profile email address. Please contact Golden Frog support with the email address linked to your Golden Frog account so that we may research this issue properly.

Thanks,
Rob
Golden Frog Support

It doesn’t work on my 15.04 install either. Definitely seems to be caused by the upstart to systemd move (https://lists.ubuntu.com/archives/ubuntu-devel-announce/2015-March/001130.html, https://wiki.ubuntu.com/SystemdForUpstartUsers). You can work around the inability to install the package by temporarily creating start and stop as links to /bin/true somewhere earlier in the path, but it’s necessary to start /usr/sbin/vyprvpn_service manually (and maybe /usr/sbin/vyprvpn_chameleon ?). Otherwise the only error is a failure to accept login credentials.

Alternatively when starting your machine you can choose to use upstart instead of systemd in the advanced options on the grub bootloader.

Would be great to have a proper fix for this. Like it or not systemd appears to be coming to stay. If I get chance I’ll see if I can create a systemd unit and post back here.