From this build I always have to connect twice or more

From this build I always cannot successfully connect to a location at the first time, and I have to hit on reconnect button and then most likely I got connected, sometimes I have to hit on reconnect button again and connected.

I feel awkward because I don’t understand why I always get connected at the second time. It is a coincidence or a bug? Please investigate.

Hello, @Jerry

I’m sorry to hear you’re having trouble getting connected.

Does this happen with every server you try? What is your ping time looking like to the servers you’re attempting to connect to?

Have you tried connecting with all of the available protocols? If not, I would test out the other protocols to see if the issue persists.

We look forward to your reply!

Golden Frog Technical Support

Hi Logan, thanks for quick reply.
Yes, it’s the same for every location server, Hong Kong, Japan, LA, etc. The ping time is perfect and good. When I get connected after the reconnect, the connection speed is perfect too. Regards the protocol, I always use your Chameleon 256 bit to avoid being censused.

Hello, @Jerry

I’d recommend trying to connect with a different protocol to see if you experience the same issue.

I would also recommend uninstalling and reinstalling the app to determine if there is an issue with the app itself, though given the symptoms you are experiencing, I do feel it is unlikely.

Golden Frog Technical Support


I am having the same problem. Using “connect to fastest server” I often get a timeout, but after a reconnect everything goes fine.

With PPTP, IPsec it seems to work fine, but with OpenVPN and Chameleon I have the issue stated above.

In the firewall settings I allow all incoming and outgoing request on any port and any protocol for vypervpn.

Best regards!


We are very sorry for any delay. To properly assist you with your connection speed issues, please reach out to our support team at: If you find you are unable to reach this alternate URL please email our support team directly at


Technical Support

Hi, I also recommend you to change the protocol you are using to see if you experience the same issue. To learn more about protocols, see this link