IOS + Certificate Trouble

Hi there,

After I deploy the cloud version in my instance, I did manage to connect to it via my Macbook. However, when I tried to connect to the VPN from my iPhone (iOS 13.1.3) with the latest VyprVPN app, it threw me an error, which mainly complained about the Certificate Error.

Also tried:

  • I removed the old cert and reinstalled it once again, but it was still a vain attempt.
  • I tried to find the cert that installed on my MacBook, but I don’t think safari would let me do it even I did look into the key-chain -> cert.

Thanks in advance.

Hey @benbenbang!

Thanks for bringing this to our attention, we will look into this, in the mean time can you please ensure your time & date are accurate and to ensure our teams success in resolving this, please submit your logs as this will provide more info on your configuration that will help!

Hi @Johnny_G,

Thanks for getting back to me.

I confirmed that my time zone and date time…etc are all accurate, and since they’re all automatically controlled by my iOS which means I am in the right timezone. To add some more info about the date time stuff, I am also in the same time zone as my instance which is in eu-west.

Secondly, regarding the logs, if I understand well about the logs you were asking is my configuration of my server (?) If so, the configuration did not change much comparing to the instruction on the official site. The only difference is that I did click on the button to generate a new cert. I am not sure it’s gonna be a problem or not.

Thanks, and have a nice weekend.

Hello,

Thank you for your reply. Generating a new cert from the server isn’t what caused this.

We have recently identified an issue with iOS 13 devices connecting to VyprVPN Cloud servers using the VyprVPN app. It’s something that’s being investigated and we’ll have it corrected as soon as possible.

In our testing sessions, we were able to get our iOS 13 device connected to our VyprVPN Cloud server, but only by using the instructions here - https://support.goldenfrog.website/hc/en-us/articles/360004786631-VyprVPN-OpenVPN-App-for-iOS-7-

To get the OpenVPN configuration files for your server, you’ll need to create them from the VyprVPN Web Management Interface using the instructions here - https://support.goldenfrog.com/hc/en-us/articles/360004391012-Create-OpenVPN-files-for-third-party-software

If you’d like an email update when the problem has been resolved, please email us at support@goldenfrog.com and reference my answer in your message to us. We can then set it so that you’ll get an email notification once the problem with iOS 13 devices connecting to VyprVPN Cloud servers through the VyprVPN app has been resolved.