iPad mini connection problems

I recently installed VyprVPN on my Apple devices, working fine on Mac and iPhone but it loses connection (seems randomly) on iPad mini 4. Happens 2-3 times a day, it goes into a frenzy of connect/disconnect. I had to disable auto-connect so I can use internet, I manually enable VPN every time I use my iPad. It seems like the problem happens after iPad wakes up from being idle. All software and apps are up to date.

Hello, @fethon!

I’m sorry to hear you’re experiencing this issue with your iPad. I’d be happy to help!

As a troubleshooting step, I would like you to uninstall and reinstall VyprVPN and the VyprVPN certificate using the instructions below:

  1. Please uninstall the VyprVPN application from your iPad.

  2. Go to Settings > General > Profile > Then delete any VyprVPN Certificate(s) you see.

  3. Next, please visit this link on a browser on the iPad:


On this page, click on “Install”, and then once again hit “Install” on the warning screen. You can exit the web browser once the certificate is installed.

  1. Install VyprVPN from the App Store once more.

Once this has been completed, please test your iPad once more to see if the issue persists and let us know the results!

Thanks for your time.

Golden Frog Technical Support

Thanks a lot Logan, I think your suggestions fixed the problem! It certainly looks different now, VPN resumes almost as soon as the iPad wakes up. There were no certificates that I could see before I downloaded them, my iPhone also has no certificates, although it hasn’t showed the problem, shall I do the same just in case?

Hello, @fethon

I’m glad to hear it’s working normally for you now! No further action should be required on your part.

If you ever find yourself experiencing this issue or any other issue again, please don’t hesitate to open a ticket with our support team here:


We’re available 24/7!

Golden Frog Technical Support

The settings i guess would be almost the same, correct me if i am wrong support.

Hi there
I’ve installed VyprVPN in my mini ipad but initially I had several connection issues, where the connection dropped without no reason.
After I follow the steps proposed here and installed the certificate but despite the vpn connection was working, I wasnt able to access the the website/channel that I wanted to stream video from. I use VyprVPN in my iphone to access the same website and Im able to stream video without issues.

Now, I uninstal the Vyprvpn and retry to follow the above steps once again, but when I try to download the app from apple store, its saying that the Vyprvpn app is not supported for mini ipad??!

Can you please provide guidance what to do next?

Hello Joaophinhos,

Thank you for contacting us via our official forums.

The issue with the application not being supported is a known issue we are currently investigating.

At this time we ask that you use the following steps to set up a manual connection while we address the app store issue.


If you have any further questions please feel free to contact our support team directly via e-mail (support@goldenfrog.com) or through our live support chat and we’d be happy to help.

Golden Frog Support


I’ve tried all the steps above and despite these momentarily fix the issue the reality is that on following day the issues arise again.
This only happens with ipad mini. On IphoneI dont experience the same issues. The is there is a glitch or bug for Ipad mini that requires a fix.

Can you please review & and provide a fix that works for more than 1 day?


Hello again Joaopinhos,

We are sorry to hear you are still having issue with your iPad mini.

Shortly after your last post we did release an update that was meant to fix the issue you last reported.

Is your mini currently running the latest version of our application?

If it is there may be an under lying cause. We’d be happy to work with you some more directly.

Please contact our support team either via e-mail (support@goldenfrog.com) or through our live support chat so we can get this issue resolved for you.

Golden Frog Support

Hi…I just tried to use it tonight with my M2P and used a brand new certified USB to lightning cable and the DJI GO 4 app would not connect to the remote. I finally took the mini off of the remote mount and tried using the much shorter DJI micro usb to lightning cable that came with the remote. At first I had no luck, but then I tried wiggling the lightning connector slightly and suddenly the App connected.

order pcb

Even I am also confronting with the same consequences.I want to include that I am unable to factory reset my iphone without password.I have followed all the manual guidelines as instructed by the support iMessage not working on Mac

  1. Back up your iPhone, because all the data will be erased by a factory reset.
  2. Connect your phone to your computer with the USB cable and launch iTunes.
  3. Click on ‘Restore iPhone’. …
  4. From the iTunes dialogue box, click ‘Restore’.
    Suggest us if we have to include anything.