Is VyprVPN using an unsafe outdated version of OpenVPN?

Hi I’m using the latest VyperVPN v2.10.0.7514. I use Secunia PSI to update my apps. I noticed that it’s showing an outdated version of OpenVPN. (Version 2.3.11.0) The latest version of OpenVPN is 2.4.3 and the old stable version is 2.3.17. According to OpenVPN website there are known vulnerabilities in these releases.

You can check for yourself C:\Program Files (x86)\VyperVPN\OpenVPN\bin\openvpn.exe.

Anybody have an answer for what’s up with this?

Hello @RaceRed ,

Great question! The core OpenVPN version you see in the install folder may not be the latest, but the TAP adapters for OpenVPN we use within the app are up to date.

I would like to note that we are always vigilant regarding security vulnerabilities that may impact our customers. If anything arises, we will issue updates to ensure our users are using the most secure version of components like OpenVPN.

Thanks for the update. Much appreciated.