MikroTik router

I am trying to get my Mikrotik router RB2011UiAS, I have enabled the pptp client on the router, but when it trys to get. It says authentication failed.

Anyone else using am mikrotik router?
Kevin

Hello @kdoswald,

I am sorry to read that you are experiencing an issue trying to connect to the VPN on your Mikrotik router due to receiving an authentication failed error message. Please verify that you are entering your email address exactly as it appears on the account because usernames and passwords are case sensitive. Also, please verify that you are entering the correct credentials by making sure you are able to login to your account at our website. https://www.goldenfrog.com/login

As we do not currently support setting the VPN up on any router, outside of using the DD-WRT or Tomato Firmware, please note that support for such will be limited. Below I am providing you with setup instructions specific to Mikrotik so that you may verify you compare your setup with it. Again, I can not guarantee that you will be able to connect using the below setup.

  1. From within the Mikrotk router interface, click the PPP tab on the left hand side.
  2. In the PPP window that pops-up, click the plus sign and add a new PPTP client.
  3. In the New Interface window that pops-up, click the Dial Out tab and enter the VPN server address in the Connect To box. A list of the VyprVPN server addresses can be found at https://support.goldenfrog.com/hc/en-us/articles/203733723-What-are-the-VyprVPN-server-addresses-
  4. Enter your username and password in the appropriate boxes.
  5. Click on the General tab and type in VyprVPN (or whatever name you wish to call the VPN connection) in the name field
  6. In the MaxMTU and MaxMRU boxes, enter 1400
  7. Click Apply button on the right hand side
  8. Click on the IP tab on the left-hand side of the Mikrotik router interface and select Firewall.
  9. Click on the NAT tab of the Firewall pop-up box.
  10. Click on the plus sign to add a new NAT rule.
  11. In the NAT Rule pop-up box, click the General tab
  12. In the Chain box, enter srcnat
  13. In the Out. Interface box, select VyprVPN (or the name you called the VPN Connection)
  14. Click the Action tab and in the Action drop-down menu, select Masquerade
  15. Click OK
  16. Click on the Mangle tab in the Firewall pop-up box.
  17. Click the plus sign to add a new mangle rule
  18. Click on the General Tab of the Mangle Rule pop-up box
  19. In the Src. Address, enter the IP range that you want to route through the VPN (normally 192.168.88.2-192.168.88.254, exclude the Router IP address!)
  20. Click on the Action tab
  21. For the Action drop-down, select mark routing
  22. For New Routing Mark, type a name for the routing mark, like Vyprvpn
  23. Click OK
  24. From the Mikrotik router interface, click on IP and select Routes
  25. Click on the Routes tab
  26. Click on the plus sign to add a new route
  27. Click the General tab
  28. In the Dest. Address box, enter 0.0.0.0/0
  29. In the Gateway drop-down menu select VyprVPN (or whatever you called the VPN connection)
  30. In the Routing Mark dorp-down menu, select Vyprvpn (or whatever you called the routing mask setup above)
  31. Click OK
  32. From the Mikrotik router interface, click IP and select DNS.
  33. In the Servers field enter 8.8.8.8
  34. Click on the Static button
  35. Change server to 8.8.8.8
  36. Click OK
  37. Click Apply
  38. From the Mikrotik router interface, click IP and select DHCP Client
  39. Double click on the DHCP Entry and uncheck Use Peer DNS
  40. Click OK

Now reboot your router and see if you receive the authentication failed error message when attempting to connect to the VPN.

Regards,
Samuel