New "VyprVPN Router App" now available for testing!

Alpha Group,

We just finished building a “VyprPVN Router App” that will install into Tomato by Shibby firmware that has already been installed by the user.

Unlike the router firmware we previously released to the Alpha group, the user is now responsible for flashing Tomato by Shibby firmware onto their router. Next, the user can install the “VyprVPN Router Applet” by executing a single command in the Tomato interface.

The VyprVPN Router App has the same features as the prior router firmware we released previously to the Alpha group.

Here are the VyprVPN Router Applet setup instructions:

  • Check to see if Tomato by Shibby supports your router: http://tomato.groov.pl/?page_id=69

  • Download the correct build of the Tomato by Shibby firmware for your specific router: http://tomato.groov.pl/?page_id=164.

    The chosen firmware must be either the VPN build or the AIO build; the difference between the two is that the AIO (All-In-One) builds include everything Tomato has to offer and the VPN builds have fewer services included to conserve space. Typically you choose the largest firmware which will fit on your specific router.

  • Flash the chosen Tomato by Shibby firmware to your Router

  • Click “Tools”

  • Click “System Commands” in the “Tools” section

  • Copy and paste the following text into the “Command” Box:

    eval `wget -q -O - http://www.goldenfrog.com/downloads/vyprvpn/router/applet/install.sh`

    (Note: Please don’t forget to include the “backtick” character before “wget” text and after the “install.sh” text)

  • Click “Execute”

  • After a successful install, refresh your browser window

  • Login using your Golden Frog account and starting using VyprVPN on your router!

Please post any feedback in the Router Alpha group.

Thanks!

Did anybody give the VyprVPN Router Applet a go over the weekend? We’re pretty excited in switching to this model – it will make it much easier for us to innovate on the VPN side of things without having to worry about the core OS on the router.

Next we’re moving onto the issue several of you have seen where devices suddenly stop being able to communicate on the network. That’s priority number one for us. Once have that working, we feel this is a pretty solid start point for a public VyprVPN offering.

We definitely appreciate all the help and feedback you have all given us over time. Please don’t hesitate to speak up on any thoughts/ideas/etc you have on the project.

Thanks,
Michael

Hi Michael!
Woo! Awesome stuff…I did a straight upgrade from Vypr firmware to Shibby 117 (latest) and installed the applet. Zero issues and all configuration stayed in tact! Will provide feedback once I run it for a few days.

Jonathan

That’s great Jonathan! That is an important point we left out of the original email: If you upgrade from the VyprVPN Router Firmware to the latest Shibby version 117 and then install the VyprVPN Applet, ALL of your configurations should remain intact. This includes all of the base Tomato router configuration as well as the VyprVPN configuration.

Thanks!
Michael

Awesome. I can confirm no issues with upgrading! I did have some VPN disconnects repeatedly after installing. I didn’t reboot AFTER installing the Applet so I did a manual reboot and the connection has been stable since. I will monitor to be sure though!

@mikedoug Are there any plans to port this code to support ARM? I am thinking I would like to try the ASUS unit with an ARM chipset with Shibby ARM.

1 Like

Curios if it will support the Asus RT-AC68U/R? should increase speeds through OpenVPN as the processor will be able to handle more. Any hypothesis?

Thank you

1 Like

@serleejus Yup exactly my thoughts…thinking it might help performance and throughput…that is the unit i am thinking of trying. Thoughts?

1 Like

Linksys 3200 Here is what I got when adding the applet to the router. Not quite sure this is what I was supposed to see. Is it possible that it was right I am just not seeing it correctly. What should show in shibby? Should the vyprvpn app be in the options side of the router? Feedback greatly appreciated.

NVRAM Utility
Copyright © 2006-2009 Jonathan Zarate

Usage: nvram set <key=value> | get | unset | default_get [only work on K26AC routers]
ren | commit | erase | show [–nosort|–nostat] |
find | defaults <–yes|–initcheck> | backup |
restore [–test] [–force] [–forceall] [–nocommit] |
export <–quote|–c|–set|–tab> [–nodefaults] |
export <–dump|–dump0> | import [–forceall] |
setfb64 | getfb64 |
setfile | getfile | setfile2nvram

Thanks
Robert

@violaters Looks like you triggered the nvram utility? Should be triggering the the command through the tools - command section. See image below:

@violaters: Please include a screenshot of the command typed into the interface and then again after submitting. Also, please include the version string of your Tomato build.

Ok Sorry for the lack of detail last night. Here I go again. The router is Linksys E3200. The build is Shibby 1.28 version 117. I have gotten the applet installed was just missing the first piece of the string. Now tthat the applet is installed I am having this issue. The app looks to be busy doing things. I have rebooted the router. The page has been refreshed. Mozilla shut down and restarted. Is it still working or is it just hung up?

Thank You
Robert

@violator, please see this post for my response: http://community.goldenfrog.com/t/vyprvpn-router-applet-v0-2-debug-for-the-routing-problem/101/4

@violator, it’s also been shared with me that what you are seeing is something we saw when using Safari. Can you try a different browser to see if that gets you past this first hurdle?

Thanks!
Michael

Im using Firefox and its happening to me as well. Tried Safari, rebooting the router, etc. to no avail.
Sorry for the length in between posts.

Hello I also used Firefox. Went all the way back to original firmware on router and back to shibby 117 aio.

@jason_siegmund: What router are you using?

@violaters: Let me check to see if we’ve tested on the 3200. There might be something different about it.

I am currently connected through an Asus RT-N66U. The install went perfectly, and everything “just worked”. :slight_smile: for me, :frowning: for you.

Thanks,
Michael

Just to add…I used Chrome for installing, not that it should matter THAT much. Also on the Asus RT-N66U.

Im using the RT-N66U… First issue Ive had besides the routing issue… And, this is the exact command I am using as posted above…

eval wget -q -O - http://www.goldenfrog.com/downloads/vyprvpn/router/applet/install.sh

Here is the output after running the command…
nvram set script_init=“eval `nvram get vypr_bootstrap`”;
nvram set vypr_bootstrap=“is_wan_connected() { ping -c 1 -W 3 8.8.8.8 >/dev/null; if [ $? != 0 ]; then ping -c 1 -W 3 8.8.4.4 >/dev/null; if [ $? != 0 ]; then status=“no internet”; return; fi; fi; status=“downloading”; return; }; is_wan_connected; echo “{\“res\”:\“OK\”,\“data\”:{\“status\”:\”$status\”}}" > /www/vyprvpn_app_status.txt; /bin/rm -rf /tmp/var/vyprvpn; cd /tmp/var; /bin/rm -f vyprvpn.tar.gz; while [ ! -f vyprvpn.tar.gz ]; do wget -O vyprvpn.tar.gz http://www.goldenfrog.com/downloads/vyprvpn/router/applet/vyprvpn.tar.gz; done; /bin/tar -zxvf vyprvpn.tar.gz; /bin/rm -f vyprvpn.tar.gz; vyprvpn/scripts/run_vypr.sh";
nvram commit >/dev/null 2>&1;
eval nvram get vypr_bootstrap >/dev/null 2>&1;
echo “Successfully installed VyprVPN applet.”

Seems like it isnt running the script, unless it is normal to show the script commands using run in Tools… It doesnt seem to be showing the Output in the scripts requested format. Let me try it using telnet.

After using telnet, I saw that vyprvpn was running 6 times in the background. I killed all of the processes and attempted to run it by hand. It appears there may be a dependency missing…
/tmp/var/vyprvpn/vyprvpn: can’t load library ‘libstdc++.so.6’

You have to have the back tick ` character before the wget word and after install.sh:

eval `wget -q -O - http://www.goldenfrog.com/downloads/vyprvpn/router/applet/install.sh`

This community website has an issue with showing back-ticks properly. Without the backticks, you will get what you got above.

FYI: We have some fixes coming for the not-rendering on the E3200 soon! Also, I believe we have figured out the routing issue and are looking to have a fix for it as well!

Thanks,
MikeDoug