New "VyprVPN Router App" now available for testing!

@jason_siegmund: You are correct that it does not auto-connect on start. That’s probably the most often requested feature and it’s on the roadmap. As for not reconnecting, I’ll have our developers look into it and get back to you.

Hello Mike,

Would like to report that after I posted screenshot and let the router run for a bit. It was unplugged and on to it’s next test. Well got it plugged in and logged in with phone to start vpn. What it is not there. Tried to get it installed and was a no go. Is it possible that it just disappeared?

@violaters, can you send me the output from: nvram show |grep vyprvpn

Please DELETE the lines with your username and password in them before posting them. And if you’d like, you can private message me if any of the contents concern you for public view.

Also, the logs would be good to have as well.


@jason_siegmond: Can you please let me know what version of the applet you are seeing the connect and retry problem on? It was broken in 0.2.1 and earlier but should be fixed in 0.3.0. If you are seeing the problem in 0.3.0 then would you mind sending us the logs so we can investigate? Thank you!

Im using 0.3.0. Is it ok to send them in from the applet?

@jason_siegmond: I’ll get them faster if you send them directly to: Thanks very much for your help!

hey Mike,
I seem to be having issues connecting to any server at all now. It has been awhile since i had issues. going to try reinstalling the app once again, though I do not think itll make a difference. Tried a fresh flash and NVRAM clear.


First of all, thanks very much for the feedback. Are you able to provide the logs? The instructions for doing so can be found under the FAQ topic. You can send them directly to my email:, and I’ll take a look at them right away. Thank you!

Hi @mikedoug & @kmata - any update on ARM support - I’ve just received an RT-AC68U that I thought would support the router app but am now not certain that it is supported. I will have to try other the standard VPN section in the mean time.

I’d love to help provide feedback for the ARM release - is there any information I can provide or any progress to report?

@asdf: We are most likely about a week (two max) away from publishing the first official Beta of the VyprVPN Router Application. This will include the release for Tomato Shibby on ARM.

I know we’ve been a bit quiet here with the Router work as of late with the Alpha group – but we are still progressing on it and are looking forward to the release.


Thanks for the update, @mikedoug - any additional news to report on ARM release? I’d love to try this alpha/beta over the weekend :smile:



Soon – very, very soon!


OK, looking forward to it! I’ll start holding my breath :smile:

@asdf Thanks for being patient! While you wait for the release - here are some screenshots of the new Router App so you can see the new interface:

1 Like

:hushed: Stop teasing!

Looks great. Can’t wait.

@asdf We have brand new build of the VyprVPN Router App. Version 5.0 is the final alpha build before we push it into public beta.

Setup Instructions here:

Please try it out and tell us what you think.

We appreciate your patience!

1 Like


We posted setup instructions for the final alpha build of the Router app yesterday:

Please try it out and tell us what you think!

Thank you! I’m away for the next week but will be sure to give it a good test on my return! Well done!