*New* VyprVPN Router App Version 0.5.0, Last Alpha Build Before Public Beta!

Alpha Group - Thank you for your patience while we’ve been working on our last Alpha build! We appreciate your feedback and it has been instrumental in the development of the VyprVPN Router App so far. We anticipate the public Beta being released very soon!

Please reply to this forum post if you find any new defects. Thank you.

Change Log for the New VyprVPN Router App Version 0.5.0

  • ARM support! You can now flash Tomato to your ARM router and install VyprVPN Router App
  • Re-branded as VyprVPN Router App
  • Add VyprVPN output to syslog
  • Added ability to connect via the header
  • Newly redesigned and restyled user interface
  • New header and navigation styling
  • Redesigned Per-Device VPN page
  • Added “Improve VyprVPN” section
  • Add link to Golden Frog forum in the header
  • Several bug fixes and performance enhancements

Known Bugs:

  • Duplicate entries on the Pe -Device page tables
  • Intermittent PPTP connection issue

VyprVPN Router App Alpha Setup

To install the VyprVPN Router Beta application on your device, complete the following steps:

Step 1: PRIOR BETA TESTERS: Please uninstall the VyprVPN Router application from your device if a previous version is installed! If you do not have VyprVPN Router installed, skip to step 3.
To uninstall, complete the following tasks:
1a. Click Tools.
1b. Click System Commands in the Tools section that opens.
1c. Copy and paste the following text into the Command box:

for v in `nvram show |grep vyprvpn | cut -f 1 -d=`; do nvram unset $v; done; nvram commit

Step 2: Reboot the router.

Step 3: Verify that your router is supported by Tomato by Shibby: Check the supported routers listed at http://tomato.groov.pl/?page_id=69

Step 4: Download the correct build of the Tomato by Shibby firmware for your router: http://tomato.groov.pl/?http://tomato.groov.pl/?page_id=164

You must select either the VPN build or the AIO build.
The AIO (All-In-One) builds include everything Tomato has to offer. 
The VPN builds include fewer services--to conserve space. 
You typically choose the largest firmware that will fit on your router.

Step 5: Flash the appropriate Tomato by Shibby firmware to your router.

Step 6: Click Tools.

Step 7: Click System Commands in the Tools section.

Step 8: Copy and paste the following text into the Command box:

MIPS Routers:

eval  `wget -q -O - http://www.goldenfrog.com/downloads/vyprvpn/router/app/tomato/mipsel/install.sh`

Note: You must include the backtick character ` before and after the text string that begins with "`wget" and ends with "install.sh`".

ARM Routers:

eval  `wget -q -O - http://www.goldenfrog.com/downloads/vyprvpn/router/app/tomato/arm/install.sh`

Note: You must include the backtick character ` before and after the text string that begins with "`wget" and ends with "install.sh`".

Step 9: Click “Execute”

Step 10: After the installation completes successfully, refresh your browser window.

Step 11: Click on “VyprVPN” in the side navigation menu and login using your username and password.

You are ready to start using VyprVPN on your router!

Please submit any feedback or bugs to this forum.

Thanks for testing everyone!

This topic is now unlisted. It will no longer be displayed in any topic lists. The only way to access this topic is via direct link.

This topic is now listed. It will be displayed in topic lists.

Looks great and working well for me so far. Will update in a couple of days when i test more options.

The listed links for Shibby are not correct.

Supported Routers - http://tomato.groov.pl/?page_id=69

Downloads - http://tomato.groov.pl/?page_id=164

@kevthehermit Thanks for the correction for the broken Shibby links!

Setup instructions have been corrected.

Hello, Ive been trying to install this after having the old app uninstalled since about july and I am getting Installing VyprVPN Router App… failed. What logs can I check?

Thanks
Jason

Hi @jason_siegmond,

We saw that issue during testing, and, at least in testing, it was due to the fact that a stale path remained in the nvram, and the new router app could not be installed until we cleaned the stale vypr data out of nvram. This was because the stale data was basically a “bootstrap” script, that was trying to download a no-longer-existent app in the background. So until the stale nvram data was removed, the new router app could not be installed.

What happens when you type: nvram show | grep vypr ?

Is there any old vypr data still remaining? If so, you can follow steps 1 and 2 above in VyprVPN Router App Alpha Setup for prior testers, which basically involves unsetting all vypr data in nvram, doing an nvram commit, then rebooting, then trying the install command again through the UI.

Another reason I can think of for seeing that error is if you are running the ARM build on a MIPS router or vice versa. We have one link for ARM and one link for MIPS, and although the initial portion of the install process will be successful when downloading from the wrong link, the install process will report failure since the vyprvpn binary will be unable to run on incorrect architecture.

These are the two initial trouble-shooting ideas that come to mind. However please let me know if you continue to have installation problems. If that is the case, additional information will be helpful - what is the model of your router? Can you send us a list of processes running on your system? What files exist in /tmp? In particular I’m looking for the existence of the vyprvpn_lock here. Has the /var/vyprvpn directory been installed? Also we have moved all our logging to the syslog, so could you please send us the /var/log/messages file?

Thanks so much for your help. We’ve been working hard on the latest version of this app and so we really appreciate your feedback!

Katie

Hi Katie, I am going to check the grep in a second. It disconnects my pptp then fails,the way it is looking.

script_init=eval `nvram get vypr_bootstrap` 

vypr_bootstrap= /bin/touch /tmp/vyprvpn_lock.$$; /bin/mv -n /tmp/vyprvpn_lock.$$ /tmp/vyprvpn_lock; if [ -f /tmp/vyprvpn_lock.$$ ]; then rm /tmp/vyprvpn_lock.$$; else status=“downloading”; echo “{“res”:“OK”,“data”:{“status”:”$status"}}" > /www/user/vyprvpn_app_status.html; cd /tmp/var; /bin/rm -f vyprvpn.tar.gz; while [ ! -f vyprvpn.tar.gz ]; do wget -O vyprvpn.tar.gz http://www.goldenfrog.com/downloads/vyprvpn/router/app/tomato/mipsel/vyprvpn.tar.gz; sleep 5; done; /bin/kill -SIGTERM “$(pidof vyprvpn)” 2>/dev/null; seconds=0; while [ “$(pidof vyprvpn)” ]; do sleep 1; seconds=$((seconds+1)); if [ $seconds = 10 ]; then /bin/kill -9 “$(pidof vyprvpn)” 2>/dev/null; fi; if [ $seconds = 15 ]; then break; fi; done; /bin/kill -SIGTERM “$(pidof openvpn)” 2>/dev/null /bin/kill -SIGTERM “$(pidof pppd)” 2>/dev/null /bin/rm -rf /tmp/var/vyprvpn; /bin/tar -zxvf vyprvpn.tar.gz; /bin/rm -f vyprvpn.tar.gz; vyprvpn/scripts/run_vypr.sh; rm /tmp/vyprvpn_lock; fi
vyprvpn_analytics=0
vyprvpn_app_avail=false
vyprvpn_app_version=0.4.1

vyprvpn_connected_ip=0.0.0.0
vyprvpn_connection_time=-1
vyprvpn_defbind=3
vyprvpn_reconnect=0

Ill be… 0.4.1 is still listed. I already ran the removal script 3 times with the same issue occurring. Am I going to have to clear my nvram?
Also, while running the removal, I am now getting this : /tmp/.wx92ajcy: line 5: **nvram: not found
cut: the delimiter must be a single character
Commit… done.

My router is an rt-n66u running Current Version: 1.28.0000 MIPSR2-117 K26AC USB AIO-64K

@jason_siegmond:

I’m at home and I don’t have my router with me so can’t check the command to see if it’s correct, but it looks like the markup in the above post added some asterisks that shouldn’t be there. I believe the correct command is this:
for v in `nvram show | grep vyprvpn | cut -f 1 -d=`; do nvram unset $v; done; nvram commit

So try running that again, then of course, check the nvram again to see if it did in fact successfully remove the vypr variables, then run the nvram commit, and then reboot. When you reboot, those vypr variables should be gone from nvram and you should be able to perform a fresh install.

Sorry for the mistake in the above copy!

Please let me know how that goes for you!

Thanks,
Katie

Ok Katie. That worked for the install, but now the app will not connect. Same issue I had with the old app. How can I get you logs?

@jason_siegmond:

What server location and protocol are you using to connect? Also, I’d like to determine if you have any network issues that could be preventing you from connecting - before you attempt a connection, what is the output of this command when run on your router:
traceroute 8.8.8.8

We’ve moved all our logging to the syslog, /var/log/messages. The syslog gets rotated pretty fast by default though, so it’s most helpful to copy it off the router right after the failed connection (unless you have configured the syslog through tomato to be larger of course). Could you please send this file to: kmata@phmgmt.com?

Thanks so much! We’d like to get you up and running!

Katie

@jason_siegmund: You mentioned using PPTP earlier, and we do know that there is a recent failure with PPTP which Katie has been looking into. The last she and I spoke it sounded like it was a regression in the most recent version of Shibby Tomato – can you share what version of Shibby you have installed as well?

Thanks,
Michael

@jason_siegmund,

Okay – I see you already state that you’re on Shibby 117 – he now has 123 out for MIPS and 124 out for ARM. You could try upgrading your Shibby Tomato version to see if there’s any mileage to be had there.

I am grabbing the newest version now. I sent Katie some info regarding what is happening - nvram settings, ps, and traceroute for googles dns. I think my DNS was messed up earlier as I could not get to the forums. That seems to have cleared up. Again, thanks for all of the help.
Jason

OK… I made a typo… I am using my PPPoE account to connect to the internet via Verizon. I have tried Numerous US and the Canadian server to get around this also different protocols. I use Chameleon because some of my subscribed sites do not allow standard vpn connections. It just seems as if it hangs while connecting, then the process, according to the router app, isn’t running.

New firmware did not help at all, although I was able to tweakmy wireless for higher speeds and manage the interference. I sent the logs to @kmata after a failed attempt to connect. I hope it helps to find this odd bug!

@jason_siegmund,

Let me get this straight – when you connect to VyprVPN it causes your PPOE to fail and disconnect?

Thanks,
Michael

@jason_siegmond:

Thanks for the log - unfortunately it looks like the log rotated too fast and I didn’t get to see the logging during disconnection. There are a couple workarounds to this - you can increase the size of the syslog file via tomato (go to Administration->Logging, then change the value of “Max size before rotate” from 50 KB to a larger value, such as 2-3 MB or so. Just as an FYI, the “Save” button is at the bottom of the page where it’s not super-visible. And/or you can also include the /var/log/messages.0 file in addition to the /var/log/messages file since when syslog rotates, it moves the current messages file to messages.0).

Also, when you updated the firmware did you clear the nvram or did you leave it as-is? I remember seeing one case in support where a customer was simultaneously configuring OpenVPN through the tomato GUI as well as through the VyprVPN links. Configuring OpenVPN through the “VPN Tunneling” link in the tomato GUI left “hooks” in the nvram that triggered code in the tomato firmware to run, interfering with our firewalls and routing tables. To fix this problem, we had to clear nvram, then install the router app again through the GUI. Not sure if that’s a possibility with your router, but I thought I’d mention it just in case.

But hopefully if you can get logs showing the failure to connect, that would provide some important additional information.

Thanks once again!
Katie

Installed this App version on the E3200 and I am up and running at home. I opened a ticket(#434479) yesterday via the support link in the app - was experiencing a problem connecting to the SF servers with Chameleon protocol while setting up the router at work. There are logs attached to the ticket. Feel free to take a peek.