*New* VyprVPN Router App Version 0.5.0, Last Alpha Build Before Public Beta!

Thank you for sending us the logs as this gives us valuable information.

We are currently reviewing the information in your ticket and will continue to reach out to you in the Support Ticket that was opened for this issue.

Thank you,
Josh

I just installed under Tomato, VyprVPN Router App.Version 5.0 but when connect to OpenVPN the state remains to “Connecting”, and I have not Internet. The only solution is reboot the router.
I returned again to original ASUS firmware.
My question is with Tomato installed is need it to fill the original Tomato “OpenVPN Client Configuration” fields or only the fields for VyprVPN Router App.Version 5.0.
As already I said with the 2 configuration filled, when connect to Openvpn remains as “connecting”.
I’m using PPOE.

@Teddy You do not need to fill out the OpenVPN Client Configuration if you have the VyprVPN Router applet installed. The connection/settings are handled in the VyprVPN tab only.

I have experienced some delay in the connection process myself, but it has been successful. How long is it stuck in that state? After rebooting or powercycling the router, are you able to get connected?

@ Teddy,

Just to expand on what Nick said, if you have already configured the VPN via the Tomato UI, you may need to clear the nvram to remove the conflicting settings. This can be accomplished by going to the Administration->Configuration page in the Tomato UI, then selecting “Erase all data in NVRAM memory (thorough)” from the “Restore Default Configuration” menu, and clicking “OK.”

When the router reboots, you can install the router app by going to the Tools->System Commands page and entering the following command:

if you have a MIPS router:
eval `wget -q -O - http://www.goldenfrog.com/downloads/vyprvpn/router/app/tomato/mipsel/install.sh`

if you have an ARM router:
eval `wget -q -O - http://www.goldenfrog.com/downloads/vyprvpn/router/app/tomato/arm/install.sh`

You should get a message that the router app installs successfully, and then when you reload the browser page, you should see the Vypr “skin.”

At that point, you should be able to log in and then connect. If at this point, you continue to have issues connecting, please send us the /var/log/messages and the /var/log/messages.0 files. What we are looking for in the log file are the messages output immediately after the connection attempt. So, the log file should include the phrase “VYPRVPN_CONNECT” in order to provide useful debugging information - we are interested in the information immediately after this phrase.

Please note that the log file by default is very small and they get rotated pretty quickly so you may need to increase the size of the log file before attempting a connection in order to capture this information. You can increase the size of the log file on the Administration->Logging page. You can increase the “Max size before rotate” field from 50 KB to 5000 KB, for example, then click the “Save” button. (However you will only need to increase the size of the log file if you are having difficulty capturing the “VYPRVPN_CONNECT” message.)

Please let me know if this solution works for you, or if it does not, if you are able to send the /var/log/message files as suggested above, we would like to continue helping to debug the issue.

Thanks very much!
Katie

Thanks a lot Nick and Katie to answer and support.
I installed again Tomato firmware and installed the “VyprVPN Router App Version 0.6.0” and the Gui looks better than Tomato original, congratulations for your well work.
You’re right Nick…the connection is succesfully after 5 minutes.
But I would need help from you…the connection is established but I have not internet because I think a DNS issue.
The connection panel says:
ConnectionYou are currently connected with VyprVPN.Connected to:➤United KingdomVyprVPN IP:0.0.0.0Time Connected:00:01:14Protocol:Chameleon.

The IP VyprVPN IP:0.0.0.0 shows 0.0.0.0
If I do a ping to google.com:
“C:\Users\Shuttle>ping google.com
La solicitud de ping no pudo encontrar el host google.com.”

But if I do ping to Google IP:
“C:\Users\Shuttle>ping 74.125.230.38
Haciendo ping a 74.125.230.38 con 32 bytes de datos:
Respuesta desde 74.125.230.38: bytes=32 tiempo=64ms TTL=52
Respuesta desde 74.125.230.38: bytes=32 tiempo=63ms TTL=52
Respuesta desde 74.125.230.38: bytes=32 tiempo=68ms TTL=52
Respuesta desde 74.125.230.38: bytes=32 tiempo=61ms TTL=52”

Then seems the DNS are not working.

My Tomato configuration for static DNS is:
Static DNS(IP:port)
8.8.8.8
8.8.4.4
208.67.222.222
Enable DNSSEC x

Seems when connect to VyprVPN, do not knows whick DNS to use.

Any idea how to solve the DNS issue?
Thanks again

@Teddy I am glad to hear you were able to establish a connection. Is this something you can replicate with OpenVPN 160/256 or PPTP? If you clear out your static DNS settings can you connect and browse? Also, disconnecting and reconnecting has resolved this for me previously, although it hasn’t happened recently and wasn’t frequent. Can you confirm this is replicable even after disconnecting and reconnecting?

It would be helpful if you could send in your logs after establishing a connection that exhibits these symptoms. To do this, open the VyprVPN menu and go to Support. Check the box to send application logs and submit the request. In the message body, type: “For Nick”

I appreciate your feedback and efforts!

Nick
Golden Frog Support

Hi Nick, I already sent you the connection log.
I trid to connect to VyprVPN for 3 times but doesn’t fix the DNS issue.
Regards

@Teddy Thank you for sending in the logs. I received them.

We will continue work in the log ticket via the Support channel, and when we have come to a resolution, a post will be made here for other users who may be experiencing this issue to see.

Nick
Golden Frog Support

@Teddy Thanks for the logs. As Nick noted, we are seeing the following lines after connection:
Dec 19 19:36:15 unknown daemon.info dnsmasq[28315]: using nameserver 80.58.61.250#53
Dec 19 19:36:15 unknown daemon.info dnsmasq[28315]: using nameserver 80.58.61.254#53

Instead for a connection to the United Kingdom server, we should be seeing dnsmasq using these DNS servers (the ones pushed by openvpn):
209.99.22.53
209.99.22.54

So I absolutely agree with your assessment, that there is a DNS issue.

Basically the way the router code and associated openvpn up script works, is that we output the DNS servers to be used during the VPN connection to the /etc/openvpn/dns/client9.resolv file. At that point, the tomato firmware uses nvram variables, such as vpn_client9_adns, to determine how it should configure the /etc/resolv.dnsmasq file - what we would like the firmware to be doing is copying the DNS servers from the /etc/openvpn/dns/client9.resolv file to the /etc/resolv.dnsmasq. If you’d like, you can check the /etc/resolv.dnsmasq file to see whether or not it contains the correct servers (209.99.22.53 and 209.99.22.54) while the openvpn connection is up, but based on the log file that you sent, it does not appear that this is happening.

It appears that one or some of the settings you have mentioned are interfering with the firmware, so that it is not copying the correct DNS servers to /etc/resolv.dnsmasq like it is supposed to, and is instead using the old, non-VPN DNS servers.

I am especially interested in the “Enable DNSSEC x” setting that you mentioned - can you tell me how you configured it so that I can do some research on it, and try to determine how/if it is interfering?

Also, if you’re willing to try clearing nvram and running the router app on vanilla tomato firmware (that may mean reinstalling the tomato firmware) that would definitely help us determine whether or not some of your existing settings are interfering, but I understand that this is intrusive and you may not wish to do so.

I’ll be going on vacation starting today but I’d like to help you work this out so any information you can provide will be helpful, and I’ll do my best to get this figured out for you.

Thanks very much!
Katie

Katie, the nameserver 80.58.61.250 - 254 are the DNS used for my ISP company.
I put manually the VPN DNS servers 209.99.22.53:53, 209.99.22.54:53, 208.67.222.222:53, 80.58.61.250:53, 80.58.61.254:53, but doesn’t fix the issue.

Enabling or disabling Enable DNSSEC x neither fix the issue.

About to install the Vanilla Tomato would mean a hard work for me. I spend 1 week to setup the router and everything works as I want it.
I wrote a lot of scripts, because the net configuration of my ISP are hard to work with a different router than the ISP route (a Comtrand).
Question: It’s possible to create a Tomato image including NVRAM parameters and retrieve if need it? I guess the answer is no.

I have not Linux skills but Windows. But if you want you can connect remotely to my router and have a look to configuration.

Enjoy the holidays and have happy merry Xmas.

Well, finally I started VyprVPN router App. The fix was enable DHCP for the PC and then so force use the received router DNS.
But I’m not happy… I have a 100MB connection and when Vyprvpn is connected then only works to 9 or 10 MB download speed, not matter which server used…USA, UK, Spain, Italy…

Any ideas?

Regards

@Teddy We are glad to hear that you are now connected to the VPN through our VyprVPN Router app. We are sorry to hear that you are experiencing slow VPN speeds when connected to the VPN. Please note that due to the limitations of router hardware, it is expected that you will likely see such decrease in VPN speeds. In order to properly determine if you are indeed experiencing slow speeds that we can improve, please contact Support at support@goldenfrog.com

Thank you for your patience and cooperation in this matter.

@Teddy

Thanks so much for your feedback - we actually have another customer who is experiencing a similar DNS issue, and I will suggest that he try your fix, since that might help him as well. Although, I’m still not sure why dnsmasq was using the old nameservers, and not the openvpn nameservers (according to your log file.) Because if that is the case, then enabling DHCP for the PC so that it received the router DNS should have gotten the old, non-VPN nameservers, right? Is it possible that you reconfigured something on the router that enabled the firmware to correctly update the /etc/resolv.dnsmasq file? I’m curious, and also because the better I understand how people are using our software, the better I can help other customers.

Anyway as Samuel said, the slow VPN speeds are unfortunately due to limitations in the router hardware. Our CTO, Mike Douglass, has been talking about supporting Vypr on more powerful routers for this very reason. We appreciate your feedback so much, since it sounds like this is something that you would definitely be interested in. I will ask when I get back from vacation to see if this is possibly something we can devote some man-hours to.

Just to educate myself on what our customers are looking for, what routers would you be interested in seeing Vypr support for? I can’t promise that we will be able to provide it of course, but I definitely will use your feedback in future conversations about where to go next with Vypr router.

Again thanks so much for your input, and merry Christmas to you as well!

Katie

@Teddy

Also I realized I didn’t answer one of your questions. As you discovered, if you manually update the /etc/resolv.dnsmasq file, the dnsmasq process will not pick up these changes. And if you run: service dnsmasq restart, so that dnsmasq will pick up these changes, then the dnsmasq process can actually overwrite this file. The way to update the DNS settings in the resolv.dnsmasq file is indirectly - via a combination of files and nvram settings. (During development I had to look at the source code for dnsmasq on tomato to verify this.)

So that is why for an openvpn connection, our router app code has to set the DNS via the /etc/openvpn/dns/client9.resolv file and then set some nvram variables to trigger the firmware to pick up the DNS from that file and copy it to /etc/resolv.dnsmasq. It’s very indirect but it’s the way dnsmasq on tomato is designed to work.

Unfortunately, that is also why some custom tomato configurations can also prevent the /etc/resolv.dnsmasq file from being updated correctly - because either 1) the necessary files and/or nvram variables set by the router app are overwritten, or 2) conflicting nvram variables set by the user cause the tomato firmware to execute a different code path than the one that we want, and the firmware will then not update the /etc/resolv.dnsmasq correctly (with our vypr DNS servers).

Anyway hope that helps answer the question!

Katie

How is the app different than manually installing Tomato, say on an E3000, and configuring open VPN? I’m looking to do that with my old router. I recently started using VyprVPN via Giganews. One thing I do notice when having an OpenVPN 256 connection on my computer is that my speed drops from 100 MB to about 50MB (about 1/2). Is that expected? Again, I want to have VyprVPN on my laptop so that it covers all of the devices behind it. Thanks!

@GatsbyGlen,

The major difference from installing our VyprVPN Router
application with Tomato by Shibby, is that you will have the easy of access to
change server location and more selection Protocol right from the interface of
your router and not have to manually change the server host name. The VyprVPN
Router application with Tomato by Shibby provides you access to not only
OpenVPN 256 bit, but also PPTP and Chameleon as seen bellow.

As for your speeds that you are seeing when connected to our
service, there are many factors that come in to play when connecting to an
encrypted service. We would love the opportunity to look in to this issue with
you via our email support. If you could please summit a ticket to our support
team at support@goldenfrog.com with the server address that you are attempting
to connect to and how you are measuring you speed we can further assist you in
locating a solution to this issue.

Lastly, when you stated “I want to have VyprVPN on my laptop
so that it covers all of the devices behind it" are you saying that you
are sharing to you connection from your laptop to your other devices? If so, we
do not have any direct support for this, but if your laptop is connected to the
VPN and you are sharing your connection from the laptop then it would be
providing the same encrypted connection.

I hope to hear from you!

Cody
Support Team Lead

Thanks for the reply, Cody. I meant to say that I wish to have VyprVPN on my router, not laptop :smile:

I’m measuring speed via speedtest.net using the LA server. I can submit a support ticket.

Thanks!

PS, For the E3000 I believe the correct build is tomato-K26USB-1.28.RT-MIPSR2-124-Big-VPN. Doesn’t look like I can use the AIO since I only have 8MB of flash. There is also a build with E3000 in the name, but I’m not sure what the difference is.

@GatsbyGlen,

Thank you for clarifying and getting back to us on this, from Tomato by Shibby I see that K26 does support your E3000 with a few builds that we well with in the 8 MB flash memory Listed here:

http://tomato.groov.pl/download/K26/

Such as tomato-E3000USB-NVRAM60K-1.28.RT-MIPSR2-124-Big-VPN.bin witch is 7.3MB found here:

http://tomato.groov.pl/download/K26/build5x-124-EN/

As instructed, You must select either the VPN build or the AIO build. The AIO (All-In-One) builds include everything Tomato has to offer. The VPN builds include fewer services–to conserve space. You typically choose the largest firmware that will fit on your router.

The version provided atop is a VPN build witch should hold no issues with our service.

If you have any further questions please get back to us.

Cody
Golden Frog Support Team

This post was flagged by the community and is temporarily hidden.