New VyprVPN Router App Version 0.6.0 - Public Beta

We’re excited to announce the VyprVPN Router App has gone into public beta with the release of Version 0.6.0!

For full setup instructions, please visit the Golden Frog Beta page for the VyprVPN Router App:

http://www.goldenfrog.com/community/beta/vyprvpn-router

Technical Requirements:

  • Your MIPS or ARM router must support Tomato by Shibby. Supported routers located here: http://tomato.groov.pl/?page_id=69 The VyprVPN Router App currently runs on the K26RT-N or K26RT-AC versions of the Shibby compilation of Tomato firmware for MIPS, and K26ARM for ARM. Please note that routers running other versions of the Tomato firmware, such as K24 or K26, are not supported.
  • Verify that you have the correct build of Tomato by Shibby. Correct build located here: http://tomato.groov.pl/?page_id=164 Tip: You must select either the VPN build or the AIO build. The AIO (All-In-One) builds include everything Tomato has to offer. The VPN builds include fewer services–to conserve space. You typically choose the largest firmware that will fit on your router.
  • Also, please note, that we have tested the VyprVPN Router App on a clean install of Tomato firmware (meaning that we have cleared nvram during the installation process.) Customers that have set-up a custom configuration of Tomato may experience problems when the settings of their nvram conflict with the nvram settings that the VyprVPN Router App uses.
  • If you are using the VyprVPN Router App, you should not configure your VPN through the VPN Tunneling page in the Tomato UI. You should only configure your VPN through the VyprVPN pages. If you set, or have set previously, any options on the VPN Tunneling page, you will need to clear your nvram before proceeding with the installation of the VyprVPN Router App. This is because configuring the VPN through the VPN Tunneling page will store settings in nvram that may conflict with the settings needed by the VyprVPN Router App.

VyprVPN Router App Features Summary:

  • ARM and MIPS support for Tomato by Shibby.
  • Supported Protocols - Chameleon™ - 256-bit Encryption; OpenVPN - 256-bit Encryption; OpenVPN - 160-bit Encryption; PPTP - 128-bit Encryption
  • Connect to any server in Golden Frog’s network of worldwide servers.
  • “Per-Device VPN” - For each device on your network, choose whether the device is “VPN Required”, “VPN Preferred” or “Bypass VPN”
  • Automatic reconnect and ability to set reconnection attempts.
  • In-app updating after initial install and in-app change log.
  • In-app support and opt-in connection logs.

VyprVPN Router App Version 0.6.0 - Public Beta Change log

  • New: Added “watchdog” to restart VyprVPN process if it stops.
  • New: Re-designed change log.
  • New: Added timeout to improve process handling.
  • New: Improved validation messaging for the login and support form.
  • New: Added details to the connecting state dropdown.
  • Fix: Failing PPTP connections are now resolved.
  • Fix: Communication between UI and backend when WAN is disconnected.
  • Fix: Correctly syncs connection details when using multiple browsers.

VyprVPN Router App Version 0.5.0 - Final Alpha Change Log

  • ARM support! You can now flash Tomato to your ARM router and install VyprVPN Router App
  • Re-branded as VyprVPN Router App
  • Add VyprVPN output to syslog
  • Added ability to connect via the header
  • Newly redesigned and restyled user interface
  • New header and navigation styling
  • Redesigned Per-Device VPN page
  • Added “Improve VyprVPN” section
  • Add link to Golden Frog forum in the header
  • Several bug fixes and performance enhancements
1 Like

This topic is now unlisted. It will no longer be displayed in any topic lists. The only way to access this topic is via direct link.

This topic is now listed. It will be displayed in topic lists.

Is the “Help improve VyprVPN by sending non-personally identifiable app data” setting supposed to stay selected once enabled or is it a one shot deal where at the time it’s selected it sends the data?

@jinjorge That check box will stay checked if you choose to enable it and the applet will periodically send that data. If you uncheck it, it will stay unchecked. Also, whenever the applet updates, it will be unchecked by default.

Nick
Golden Frog Support Team

@nick thanks for the response. It doesn’t stay check on my Netgear R7000 running Shibby v124 AIO. Observed this with Router app v0.5.0.

Thanks!

edit: checked again on v0.6.0 and the setting remains enabled as you navigate to other router settings and back. this is not an issue with v0.6.0. apologies for the confusion

Initial Feedback on the new 0.6.0 version.

I have:

Name Primary
Model Linksys E4200 v1
Chipset Broadcom BCM4716 chip rev 1 pkg 10
CPU Freq 480MHz
Flash Size 16MB

CPU Load (1 / 5 / 15 mins) 1.34 / 1.01 / 0.66
Total / Free Memory 59.80 MB / 44.17 MB (73.85%)
Total / Free NVRAM 60.00 KB / 30.18 KB(50.29%)

WiFi:
2 Devices Required
1 Device Preferred

Cabled - Via Switch
3 Devices Bypass
1 Deivce Required
1 Device Bypass

Router is holding ok so far.

Speed test results

Bypass:
Ping: 23ms
Down: 12.58Mbps
Up: 1.07Mbps

Required: - London Server
Ping: 23ms
Down: 5.43Mbps
Up: 0.96Mbps

One thing i have noticed. The DDNS Check seems to use the VPN IP address instead of my ISP provided one. This breaks all my inbound ports on the DDNS hostname as its trying to come in via the VPN NAT.

If i go direct to the ISP IP the inbound ports still function correctly. But it makes my DDNS useless.

@kevthehermit

Thanks very much for passing along that information. I’m particularly interested in the DDNS issue since customers sometimes use our products in ways that we don’t always anticipate :slight_smile: Did you configure the DDNS through the tomato->DDNS page? We have not tested the router app with DDNS. I know that our router app and the tomato settings do occasionally “step on eachother’s feet” - I have noticed this particularly when customers use both the router app and also configure the VPN via the tomato VPN tunneling page.

You bring up an excellent point - we should communicate better to our customers what tomato options are supported and which are not supported when using the router app. Just FYI, we used vanilla firmware for our testing, with nothing special configured via tomato (such as DDNS). I will see if we can post something to this effect alongside the router download instructions.

Thanks again for your input; we always very much appreciate hearing how our customers are using our software!

Katie

Hello, thanks for developing this app!

Is there possibility to choose between VyprDNS and 3rd party DNS (in the way it is done in Windows application)?

I have DD-WRT on my router… Just wanted to check this out before switching to Tomato.

Hello @telstar92,

Yes, you are able to change between VyprDNS and 3rd Party DNS when using the VyprVPN Router app. By default, the VyprVPN Router app uses VyprDNS. To change the DNS to a 3rd Party DNS, simply go to the Basic -> Networking menu and there set the DNS IP addresses to any 3rd Party DNS. To change the DNS back to using VyprDNS, you would simply input 0.0.0.0 for both DNS server IP addresses. Click the Save button at the bottom after making the change in order for the change to take effect.

Samuel
Golden Frog Support

1 Like

Thanks for the reply!

Just tried to install the app but failed… I’m in China, and www.goldenfrog.com is blocked here, wget can’t download files… Any workaround?

Regards!

@telstar92:

Thanks for passing along that information! We’re working on a workaround for you. I will update you with that soon!

Thanks,
Katie

I also live in China and had the same problem.

I managed to work around the problem by downloading the necessary (1) files (2) directly, uploading them to an accessible online storage site (I used drivehq.com), and then editing install.sh to direct to the new url.

It took a little more time, but it worked. Perhaps it would be easier to host the files on a site that is not goldenfrog.com for those of us under the red thumb?

@jbranst:

Thanks for posting a workaround! We’re looking into doing something very similar to what you suggested, so that other customers won’t have to do what you did manually. Thanks very much for the feedback - it should help other customers until we have a chance to address it, which I would definitely like to do this week!

Katie

@telstar92
@jbranst
hey
i think there’s an easier method if you can connect via open vpn.
just set up a OpenVpn connection using this guide https://www.goldenfrog.com/support/vyprvpn/vpn-setup/tomato/openvpn
check your ip or logs to see if you have a established connection
https://www.goldenfrog.com/whatismyipaddress
then follow the steps from the 1st post on this thread

@Katie

Cool :smile:

@Saied

Actually, after the recent GFW upgrade, I haven’t been able to connect with OpenVPN, PPTP, or L2TP. I can only get through with VyprVPN’s Chameleon protocol.

I’m not sure if that’s true for everyone in China, however. Perhaps your suggestion could work for someone else having this issue.

@jbranst @telstar92 @Saied

We have a workaround now for the issue that customers had installing the router app, due to blocked access to www.goldenfrog.com.

We set-up alternate URLs for installing and downloading the router app. To install the app, please enter the following in the “Tools->System Commands” box in your Tomato UI, then click the Execute button:

For MIPS:
eval `wget -q -O - http://dl.succentric.com/downloads/vyprvpn/router/app/tomato/mipsel/install-succentric.sh`

For ARM:
eval `wget -q -O - http://dl.succentric.com/downloads/vyprvpn/router/app/tomato/arm/install-succentric.sh`

Please be aware that although this workaround should allow you to download and install the app and connect with Vypr, there are still a few places where calls to www.goldenfrog.com have been hard-coded into the app, and so I don’t expect those parts of the app to work correctly. For example, sending us a message from the support page, or checking for updates on the settings page, may not work correctly.

Hope that allows you all to install and download, and connect! Please let me know if you run into any problems!

Thanks,
Katie

Very creative app, but it seems not stable, the connection is always interrupted ( 3-5 times every day), and reopening the VyprVPN page on router will take a very long time (a few minutes).
PS: Routers: ASUS AC66U & Linksys E2500 (firmware are all the latest TOMATO), Protocols: Any (Including Chameleon), Location: Chinese Mainland.

I am sorry to hear that you are experiencing intermittent disconnects when connected to the VPN.

Sometimes certain ISP quality of service issues can cause occasional disconnects.

We would be glad to look into this intermittent disconnection issue that you are experiencing.

At this time, we cannot find an account for the email address used in your post .

Please fill out a support request here: https://www.goldenfrog.com/support/contact

We will continue to assist you in troubleshooting the issue via email.

We look forward to working with you in order to resolve your issue in a timely manner.

Josh
Golden Frog Support