New VyprVPN Router App Version 0.7.0 - Production Release

Excellent work! I have removed the 6.0 and upgraded to the 7.0 Production Release. went smoothly and only takes a few minutes.

I had tried the lasted K26RT-AC 128 EN firmware on Asus RT-AC66U, AIO version. i get error when installing the latest App. Ver 0.7

I went back to 124 EN AIO, and installed the App Ver 0.7, without problems. I don’t know what been broken in the latest version of shibby Firmware.

Hi @vigermam!

Do you recall what error you saw, verbatim? That would help us track down any possible issues with that Shibby build and the Router App.

Golden Frog Support

hi @nick that just give me a simple error message, as ‘Installing VyprVPN Router App… installation failed’.

I had tried the web command line and both ssh, telnet on EN 128.

when i switched to EN 124, i simply did that in the SSH port.
I will try again tomorrow to see if i missed something in En 128, I will NVRAM rest, and try SSH install the 0.7 on EN 128 again, and post result here.

please add direct SSID or separate SSID for vpn
(to access the internet directly)
i’ve tried to add virtual wireless and routing table but no success after vpn gets connected, there is no internet connection on virtual wireless

Thank you for the suggestion, @Saied!

That’s a great idea. One we will take into consideration for future releases of the Router App.

Golden Frog Support

Just a short question: If I want to update to the latest Router App version, what should I do? Is there a special command for it? Or does the app do the update by itself?

Hello @simpty!

To check for updates, go to the VyprVPN section of Tomato and then click Settings. There is a button labelled “Check for Updates” you can click anytime to run a manual check. However, the app looks for updates automatically once a day.

Golden Frog Support

I just wanted to let people know that I running the VyprVPN Router App on a Asus RT-N16 with Tomato package - just an FYI

1 Like

Hii, I have been using the Router App for a while now - the Auto Reconnect Feature does not seem to really work for me…any idea?


Please contact our 24/7 support team via email or live chat so we can investigate. To speed up the process, it may help if you can provide us with the following details initially:

Are you experiencing this after rebooting the router? Or is the router staying on, and simply closing the connection at which point you cannot reconnect?

Are you running version 0.7 or 0.6?

Ok I will talk to chat - but just for the record

  • router running 0.7
  • auto-reconnect is enabled
  • when the connection is dropped it does not reconnect automatically

Also after reboot it does not automatically connect but thats another problem

for connect at boot, see my solution:

Hey guys, Here is a little VyprVPN Connection WATCHDOG script I created to Auto Connect on Startup and Reconnect and check the Connection every 90 Seconds - and then Reconnect if needed

Just wanted to say that I managed to connect to vyprvpn via pppoe. :smiley:

Using Tomato Firmware 1.28.0000 -132 K26ARM USB AIO-64K

I installed the tar via ssh and then ran the script. Not all of the servers work though.
BTW: Vypr got seriously slow, can’t even watch Youtube on 720p anymore.

Hi, I’m using the Router VPN app now since a few month here in China. I general it works fine. There is just one thing I want to highlight as a User located in China. Sometimes I was wondering why I couldn’t open the VYPRVPN setting page on my router or it took really long. First I thought there is an issue with my router. After some time I figured out that the reason are the Sylesheets which are used for the design of the Router APP.

rel=“stylesheet” href="**//**family=Open+Sans:300,400,700">""

Google is blocked in China so if I’m accessing my router from a device where I’m not on VPN it will not load the page or it takes ages to do so.
Please consider this in the design of the next version of your App.

Would be also great if you would have a second server for the installation of the app since your website is also not reachable from China. I had to setup a PPTP VPN connection with Standard tomato first in order to install your Router APP.

Other than that it works fine most of the time.


Hi there, I just installed the app on my Tomato Shibby R7000 router, but when I go to any of the pages that are installed (which was stated to be successfull) just get a blank page.

Any suggestions on what the problem might be?


Hello @Richard_Stubbington,

For clarification, are you unable to access any portion of the Tomato firmware after installing the VyprVPN Router application, or just content directly related to VyprVPN?

Does the issue persist after conducting a powercycle of the device?
Does this issue occur using multiple browsers? (If applicable)

Thank you for your feedback!


Thanks for your post