Tomato / App Version Combination

Kind regards to all,

I was woundering what tomato builds people are using with the Router App?

seems I am having trouble with the per device capability with chameleon. I am not able to get devices selected device to Bypass vpn. gone through various hard resets nvram clears etc with fresh installs.

Using R7000 Tomato by S v138. Is this the version that is tested or is the app caught up / tested to a retro version.

Again best regards to the community.

Splinter

Hey @Splinter,

We offer full comprehensive instructions regarding the set-up for the Tomato App. For best results, we recommend looking into our Hardware Requirements page and making sure your router is on the Supported Routers List.

If you require personalized assistance, don’t hesitate to contact our support team directly. We’re available 24/7.

Cheers,

Katherine
Support Team

The reason for this is because VyprVPN router app is not compatible with Shibby 138 or any other his Multi-WAN builds for that matter. To make it working properly you have to use v132. VyprVPN fails to mention this anywhere.

Thanks for your input, @dxb!

Yes, you are correct. We have determined that this is a bug with the multi-wan version of Tomato by Shibby and we have reached out to them in regards to this issue.

In the meantime you may use an earlier version of the Tomato by Shibby firmware. Any version 1.28.0000 -132 or earlier will work.

If you would like to be notified when we have a solution, please feel free to contact our support team via email, support@goldenfrog.com and reference this forum post. We can add your ticket to a list and update you when we have further information regarding this bug! (Sorry, we don’t have an ETA or any further details at this time.)

1 Like

Kind regards to all,

My understanding is Shibby is on a well deserved break for a bit. So for now it looks like there is no multiwan router point of presence solution for chameleon unless you have 2 appliances. (multiway POP > VYPR router)

I can see integrating multiway with golden frog overlay as a progressive development.

I will report back on my 132 downgrade but there are definitely a few bug fixes since 132 not multiway related.

Good luck and if possible please lets keep a bump every now and then to keep those of us following this updated… Willing to beta test as well.

Splinter

Great!

After all the trouble I went to getting Tomato 138 on my Asus RT-3200 (due to new restrictions imposed by Asus on third-party firmware) and then installing the Router app - I find that it doesn’t work.

BTW, going back to firmware that is more than a year old is not really solution.

Sorry, cancelling my account - there are better solutions available - that work.

Hello @princi,

We’re very sorry to hear this has caused you to cancel your account. Our developers are continuously working on compatibility for a wide breadth of Tomato versions and, while we mentioned we do not currently have an ETA, we are happy to notify you when we do have a solution available. Simply contact our support team and reference this forum post so we will update you as soon as we have further information available.

Cheers,

Katherine
Support Team

Hey @Splinter,

I am sorry you are experiencing these issues as well. I can confirm we are actively researching this issue and will be providing an update when a resolution becomes available.

Please let us know if you have any further questions!

Regards,
Wes
Customer Support

I am glad to see that I am not the only one having this issue.

Has anyone found any workarounds for this issue?
I suppose configuring the OpenVPN client would be the next option for this firmware?

Edit with update:
Not quite what I wanted to do, but it looks like someone created an iptable script that performs something close to what I was doing:
https://forum.hidemyass.com/index.php/topic/11775-bypassing-vpn-with-iptables-rules-ports-protocols-ipas-websites-and-more-tomato/
(It would have been nice if there was something in the UI that helps support this functionality.)

Bump

1 Like

The decent thing to do would be to update your public facing documentation of known limitations and incompatibilities with versions of Tomato.

Hello.

Yes, I am experiencing the same issue with Chameleon / OpenVPN (256bit and 160bit, both) and latest Shibby version 140. I can confirm that VyprVPN is not working yet.

Downgrading to a 1,5 year old firmware is not an option as well for me as there were many fixes (also security fixes) meanwhile.

I am sad because I bought a Tomato-compatible router to get VyprVPN router app. Now I have a router which is not compatible with VyprVPN’s implementation or/and not supported by VyprVPN. So I’m in the same situation like before :sob:

Regarding official documentation, I agree with @ArthritisEye that it should be updated with a clearly visible warning/information that VyprVPN router app is supported up to Tomato version 132 (Release date: October 2015).

I guess the VyprVPN app should be revisted by developers to adapt their implementation to be compatible with the latest Tomato version(?) again. At least it seems it is working for some VPN services.

@carlosz As you already tried to reach out the Shibby regarding this issue. May you share the link of the issue so I can vote up it. More votes = issue will be fixed earlier (usually).

One more I found while digging. Here one claims that configuration is still working with Shibby 138 when VyprVPN router app is not installed as VyprVPN router app is destroying something. But I would miss the “Per Device VPN” feature. I really appreciate this feature.

I have not tried to follow the manual configuration as described on “VyprVPN OpenVPN Setup for Tomato” without VyprVPN router app installed. But I can confirm: With VyprVPN router app installed it won’t work with most recent Shibby version (140) as well. For everyone who is not using “Per Device VPN” at all this solution may be worth it.

KR,
Christoph

My Router:

  • Netgear R7000
  • Shibby Version: 140
  • VyprVPN

When will your router app work with latest version of Tomato?

@ArthritisEye - Tomato build 132 is the last supported version of the firmware for the VyprVPN Router App. Builds after that will experience issues. We do not have any active plans to update support to a later version. The tutorial on our site has been updated to reflect support for 132.

If you would like to run a newer version of the firmware and leverage VyprVPN, you can configure a VPN connection through he native VPN client on Tomato. Tutorial: https://support.goldenfrog.biz/hc/en-us/articles/204088603

If you have further questions, feel free to reach out to us via email or chat. https://www.goldenfrog.biz/contact-support