Trouble in my network

After installing VyprVPN on my main computer (MAC mini) I ran into the following troubles.
My router (Netgear R7800) was blocked and after disabling the Nat Firewall of Goldenfrog the network could be reached again.
But then my wife could not get on the internet with her iPhone while she had VyprVPN installed. I advised her to uninstall the app which she did, but even after reinstalling her settings, the internet seemed blocked. It is not her iPhone as it connected to the internet fine when we tried it out of reach from my network.
This morning I could not log into my router with my browser. When i turned VPN of on my Mac I could log into my router with my browser and mysteriously I could get internet connection on the iPhone. Strange as it may seem, I had VyprVPN installed on my iPad and that connection had no troubles at all.
What causes this behavior?

Hello, @viper

Thanks for bringing this matter to our attention.

Connecting to the VPN from your Mac should have no bearing on any of the other devices in your network.

When you say that the internet seemed blocked, what do you mean exactly? Do you mean that she can’t connect to WiFi or cellular when the VPN is installed, or that she was just unable to establish a connection to the VPN server?

How are you attempting to access your router through your browser? Are you using the host name, or the local address of the router?

Looking forward to your reply.

Regards,
Logan
Golden Frog Technical Support

  1. “Connecting to the VPN from your Mac should have no bearing on any of the other devices in your network.” I agree.

  2. "When you say that the internet seemed blocked, what do you mean exactly?
    Do you mean that she can’t connect to WiFi or cellular when the VPN is
    installed, or that she was just unable to establish a connection to the
    VPN server? "
    No. the iPhone was connected in my network via WiFi. But it could not access the internet. Nor with VyprVPN installed, nor with VyprVPN uninstalled and the iPhone reset.
    It connected with the internet after I closed my VPN connection on the MAC.

  3. “How are you attempting to access your router through your browser? Are
    you using the host name, or the local address of the router?”
    I connect by http://routerlogin.net/

Hey, @viper

Thanks for getting back to me.

That certainly is strange behavior you are describing. Were you able to replicate this issue consistently by connecting and disconnecting with the VPN on your Mac and testing the connection of the iPhone? Could you please provide an explanation towards how your network is configured? Are you using internet sharing from the Mac, per chance?

In regards to accessing your router while connected to the VPN, please make sure you are attempting to access it from the local address of the router (typically something in the vein of 192.168.x.x) rather than by host name and see if you are still experiencing the same issue.

Regards,
Logan
Golden Frog Technical Support

I have turned VPN back on and with this method I saw no problems :slight_smile:

But when VPN was turned on I had the same problem with the iPone. :cry:
This problem seems consistent. while VPN on my Mac is turned on this iPhone does not show up in my network. when turned off, it shows up again.

My network consists of a router with

  • one Mac mini (with VPN), a NAS, Mac mini (mediacenter), TV, Bluray player, amplifier, speaker, all connected by LAN (DHCP)
  • iPhone 1(with VPN), iPhone 2 (trouble), iPad 1 (with VPN), Mac mini all connected by WiFi

Internet sharing on my Mac mini (with VPN) is turned on.

Hey @viper

Thanks for the reply. We still need clarification on the issue you are having with your “iPhone 2”. Previously, you reported that when your Mac is connected via VyprVPN, your iPhone was connected to your WiFI but could not access the internet.

In your next reply, you stated when your Mac is connected, your iPhone does not show up on your network which indicates a different issue. So we can properly diagnose what is happening in your case, please clarify these details.

If the latter is the case, I would also like to know if you are connecting to the internet on your “iPhone 2” via ICS (internet connection sharing) or if you are just connecting it directly to your WiFi network.

Can I have you also try various protocols on your Mac and see if the issue persists with your iPhone? (Here is a screenshot to assist you: http://i.imgur.com/O79QR14.png )

Thank you in advance for this information. We look forward to hearing from you!

Regards,
Wes
Customer Support

At the moment I will not be able to test it now as my wife (and her iPhone) is at work.
I will get to you later.

Hey @viper

Thanks for the heads up. Feel free to reply at your earliest convenience. We look forward to hearing from you!

Regards,
Wes
Customer Support

Hi, back again.
I have been thinking about my problem. Wouldn’t it be better if set my VPN in my router? Then it will protect all internet traffic from all my appliances (iPhones ,iPads etc.) in my network.
What is your advise?

Hello, @viper

This would be a good solution to get all devices on your network connected to the VPN. We would recommend using our router app for Tomato!

You may visit this page to see if your router is compatible with Tomato firmware:

http://tomato.groov.pl/?page_id=69

We are unable to assist with flashing your router with Tomato, and we can take no responsibility for anything that happens during the firmware setup.

Once you have the router flashed, you would need to follow the instructions on the followup support page to set up VyprVPN over the router:

https://support.goldenfrog.com/hc/en-us/articles/204103006-VyprVPN-Router-App

I hope this helps.

Regards,
Logan
Golden Frog Technical Support

I will ask advise on the Netgear support forum and see if I can get it installed. Then I will be back. Thank you very much for your help so far.

I have just learned that my router (Netgear Nighthawk R7800) is incompatible wit Tomato. So this is not going to work.
Do you have any other suggestions to get VyprVPN working on this router?

Hello, @viper

I’m sorry to hear your router is not compatible with Tomato. I have checked the compatibility databases for DD-WRT and OpenWRT (which we also support), and it does not appear your router is compatible with these firmwares, either. I do apologize for any inconvenience this poses.

Regards,
Logan
Golden Frog Technical Support

does that mean I can’t use VyprVPN on my router at all?

Hello,

That is correct. You would need to use a VyprVPN application on your devices to utilize the VPN service. Sorry for the inconvenience this may have caused you.

Please let us know if you have any further questions!

Regards,
Wes
Customer Support

I have found out that my router is compatible to DD-WRT. :slight_smile:
I am gathering information of how to apply the firmware. That will take some time as I don’t comprehend everything.
After having applied the firmware can I then apply the VyprVPN Router App or do I have to install something else first, like OpenVPN?
Will it be working both ways (in and out traffic)?

Hey @viper,

After you have installed DD-WRT, the walkthrough found on this link will be the best set-up instructions for you.

The VPN will encrypt all traffic once activated.

Cheers,

Katherine
Support Team

Thank you very much for your answer.
Can I come back to my previous problem that is not solved yet?

I have removed the VyprVPN app from her phone and had a reset. So I assume this phone has no VyprVPN istalled or working. It looks like it is using my Macmini to access the internet instead of accessing the internet directly. It is only blocked from accessing the internet when VyprVPN is turned on in my Macmini.
When the iPhone is not within reach of my network it works fine (accesses the internet). I have tried it using another network and the iPhone used the WiFi. It accessed the internet without any problems.

Hello @viper,

Have you tried going into the iPhone’s connection settings and choose to “forget” the Macmini’s WiFi? That would remove the stored password and prevent the iPhone from connecting to that network.

Do you intend to use VyprVPN on the iPhone? If so, I would suggest ensuring the VyprVPN app’s “connect on untrusted wifi” option is disabled, and add the normal wifi connection to the list of “trusted networks.” This should keep the app from connecting using the Macmini’s wifi connection.

If you actually want to use connection sharing via the Macmini, here is a guide that should help setting it up. https://support.goldenfrog.com/hc/en-us/articles/215627257-Internet-Connection-Sharing-for-VyprVPN-on-Mac-OSX

If you don’t actually use the Macmini’s connection sharing for other devices, the easiest solution would be to disable the share by removing the network.

Hope that helps!

FYI: The WiFi on my Macmini is always tured off. Even so this problem keeps coming up.
The iPhone is connected via WiFi to my router; my Macmini is connected via LAN to my router. [quote=“carlosz, post:19, topic:3460”]
If you don’t actually use the Macmini’s connection sharing for other devices, the easiest solution would be to disable the share by removing the network.
[/quote]

I do not understand exactly what you mean by this.
On the Macmini Internet Sharing is disabled.

On my iPhone (not the one with the problem. Lets name it iPhone 2) I have VyprVPN installed and it has no prolems connecting to the internet if VPN is on when the Macmini is running VPN. ???
iPhone 1: having problems. It has the VyprVPN app removed and is reset.
iPhone 2: having no problems when VPN on the Macmini is on.