V3.0 Does not work with Windows 10 Professional

Version 3.0 does not even run on Windows 10 Professional!! It starts to run and then immediately shuts down. No chance to login or do anything. I have disabled my Virus Protection. Run the installation as Administrator and it always fails. Where can I download the previous version!

When you uninstall the previous version, you have to make sure you check the “remove user settings” box, otherwise the new installation will crash.

There is a link to the old version in the “no transfer speed graph” thread.

Thank you @Matt for the response on this post! These are the correct steps we would have suggested when you run into issues after upgrading to 3.0 on Windows 10. Those steps are as follows:

  1. Manually uninstall VyprVPN. (when you are asked which components to uninstall, make sure you check the box next to VyprVPN User Settings.)

  2. Reinstall VyprVPN by right-clicking the install file and selecting “run as administrator”. (Available here: https://www.vyprvpn.com/vpn-apps/vpn-for-windows/download )

If the issue continues feel free to reach back out or contact our support! https://www.goldenfrog.com/contact-support

I’ve tried everything suggested. None of that works. Version 3.0 is useless on my Window 10 Professional PC. What ever you did to update this software, you ruined the software. Your software worked for almost 4 years! But, not now.

We show that you already have a support ticket opened with us. We will be able to continue working with you there so we can better troubleshoot this issue with you.