VyperVPN Disconnects but says its connected

After exiting sleep mode on my computer VyperVPN will disconnect but show that it is connected. The only way to tell if it’s truly connected is to look at the network traffic. I have verified the disconnect by reviewing my public IP after returning from sleep mode

Hey @Flynn

Sorry to hear you’re running into this issue. It is common for applications to ‘stick’ when the computer wakes from sleep mode. However, the application should catch up with itself, so to speak, and show it is disconnected shortly after.

Do you have any specific options selected in the Settings under the Connections tab, such as the option to automatically reconnect when the application is disconnected? Do you see any change in the app’s behavior when you enable/disable this feature?

Cheers,

Katherine
Support Team

unfortunately, the application never does catches up. During some troubleshooting, it appeared the VPN was disconnected even an hour after exiting sleep mode. The key factor in identifying this was the lack of network traffic even after several hours. I do have some specific options selected in the connection tab. The currently selected options are “automatic reconnect” and “connect on start - connect VyperVPN when windows starts up”

Hey @Flynn,

Thanks for the confirmation. Do you see any change in the app’s behavior when you disable the reconnect feature?

Cheers,

Katherine
Support Team

Hey @Katherine

I’ve done some troubleshooting with the reconnect feature disabled but it doesn’t fix the issue. To give you an idea of how I’m testing I basically connect to the VPN and get my VyperVPN IP then I cross check that IP with google then I put my computer in sleep mode and wait for it completely enter sleep mode then I wake the computer up and then cross check my IP again. I always have a different IP than what the VPN App is telling me I have and it still says it’s connected to the VPN. I’ve provided another screenshot of the network monitor to hopefully better explain the transition from being connected to being disconnected but giving a false positive


You’ll obviously notice the drop in network activity at the end of the chart that perfectly correlates with going into sleep mode

Hello @Flynn,

When the app auto-reconnects, it would be expected behavior to have a different IP address, although the app should reflect that. After the app reconnects, does this page tell you you are connected to the VPN?

https://www.gf-app.com/whatismyipaddress

We should probably start a ticket for this so we can take a closer look. Can you send us the app logs? This will also start a support ticket.

Please click the Settings icon in the top-right corner, then mouse over Help and choose “Report a Bug” or “Contact Support”.

Next, enter in a short description of the issue and then make sure the “include application logs” check box at the bottom is ticked. Then click “Email Support”.

Hey @carlosz

I recreated the bug and verified my IP by using your link. I hope this help verify the issue


I have submitted a ticket with your devlopment team.

Hi,

I have the same issue. Apparently it happens with Paris->Amsterdam.
When i use Germany, or Switzerland it works quite better.

The worst is that after a while the traffic restart but not through the VPN. The software says it’s still connected non the less.

It would be really nice to have in the interface a Traceroute result to check if all is properly routed through the VPN.

TIA

Hello @Tex,

We have a beta version of the app now that should fix the problem and return the app to a “disconnected” state after you wake the computer up from the sleep state. You can enable the beta option via the application settings if you like. The updated live version should be released very soon, so look out for the update prompt as well.

If you continue to experience the problem, please contact our support team so we can investigate. https://www.goldenfrog.com/support/