Vypr VPN not working in Shanghai, China

Hello @AlvinDE

Our apologies for the continued trouble with the VyprVPN app.
We have sent you an email recently with an update on the situation. Your ticket number is 2982658.

Thank you.

It has been more than two months. Still no solution to the malfunction. I guess what the support team does is anything but fixing the problem.

Hello, @AlvinDE,

I see that you have a ticket for the issue you are experiencing. We apologize for the continued trouble using the VyprVPN app on your MacBook Pro.

Our dev team is still in the process of investigating the underlying issue with the connect button being unresponsive when clicked. Once we have an update we will contact you directly.

Thanks,
Support Team

I’m also experiencing this exact issue on a Macbook (unresponsive connect button). Any update?

Hello,

We have pushed out a Beta update which addresses this issue. Please go to Vyprvpn->Preferences->Account, then set Beat updates (Checkbox) and you should update to the latest Beta.

Howard
Support Team

Hello

The latest Beta still not working, but the manual connection works.

Hello @M0Vic,

Sorry you’re having trouble connecting the app on your Mac. Please reach out to our support team at https://www.goldenfrog.com/contact-support and we can assist you with resolving this issue.

Thank you for your patience.

regards,
Kayleigh

I can confirm that it is still not working. I am currently in Shanghai (Trying out a different VPN service is the only reason I can post), and cannot connect through Vypr VPN. I have been through all of the troubleshooting steps twice, once before contacting support, and again after getting direction from support. Uninstall, confirm no trace of the helper, reinstall latest version.

If anyone from Golden Frog is reading this, your directions for High Sierra and the Security and Privacy settings are not correct, there is no list under trusted or identified developers.

I too experience the “connect button being unresponsive when clicked” issue, and am running the latest version.

Hope they can fix this soon. It is disappointing that other VPN services work over here, but this seems to be an ongoing issue. I don’t want to switch services, but I may have no choice if this can’t be fixed in short order.

Hello @Hexley

Thanks for the feedback. I am sorry those steps we sent you didn’t do the trick. I have reached out to you on your current support request with more information. If you have any further questions, please feel free to respond to the email ticket and we will be happy to assist you further.

Regards,
Wes
Support Team

what is the use of opening a support ticket over and over again, if the solutions do not help ?!

Would be better if the support just looking for where the problems are and fix this time. I
myself have problems with your client, which hangs over and over again
and takes an extremely long time to connect times, when the time
connects. And when you write to the support, you have the feeling that you are not listening and you talk constantly past each other.

From a support I expect something different.

So … my request to you, really looking for the problems and listen to the user or read correctly, what the user writes. The only support tickets opening up brings nothing, especially if you talk to each other permanently.

best regards

Hello!

I understand your frustration and you can provide your feedback in the Support ticket for your issue and we will try to improve our service and help you as much as possible.

Technical Support

1 Like

I have identical issue. Located in Shanghai, China. Vypr works fine on all my devices, iphone, android tablet, PC laptop. However on the Macbook Pro running High Sierra 10.13.6 the connect to servers button is unresponsive. Tried uninstalling and reinstalling. Removed the helper file and reinstalled. All the troubleshooting tips I could find I tried and still no luck.

To me

Now it has been more than four months, and the support team has come up with NO solution at all. Like what I said in my previous post, all they did was making apologies as if they could fix the issue.

They once offered me a 30% discount as a sort of compensation, but apparently who will subscribe a vpn like this when it fails to work?

To make things worse, the solution of “TunnelBlick+VPN configurations” has completely failed to connect on my MacBook, which leaves me no choice but to unsubscribe.

this post gave the reason and solution
https://forum.goldenfrog.com/t/vypr-vpn-mac/4326/12

vyprvpn mac app uses api.goldenfrog.com to get ips of the servers.
if it fails to connet api.goldenfrog.com, the connect button don’t work.
the solution is as follows:
step 1: the iOS version works well. so you just open it and connect.
step 2:on the setting, look at the log. the log reads that it use IKEv2 vpn and you can see the ip.
step 3:on your mac, open System Preference -> Nextwok.
add an IKEv2 vpn config manually
step 4:the RemoteID is *vyprvpn.com, authenticate by your vyprvpn username and password.then you can connect.

the ip won’t work for a long time.when connection fails, do step 1-3 again with a new ip.

hope the support team can fix this soon. make the mac app work like the iOS app does may help.

please look at this post to see the solution


hope u can fix it soon

I have identical issue in China also. I have been following all the instructions to reset Vypr on macos and it fails anyway. It works well on my iPhone and iPad devices though. After many emails consultings with no solution, I kind want to give up. Hope you could work it out soon.

Hello @Iris

Sorry you’re having trouble connecting the app on your Mac. Please reach out to our support team at https://www.goldenfrog.website/support and we can assist you with resolving this issue.

You can also send the logs from the app from your Mac so we can investigate them as well. Open the application, then click Help on the menu bar at the top and then click “Contact Support”. On the next window please make sure the “Include Application Logs” checkbox is ticked, then click Email Support. This will send us the logs.

Thanks!

It seems that more and more servers are not working now.
MOST severs in Asia are not working.
Is it could be solved and how long it would be?

Hello,

We understand you are seeing connection issues in China. We have seen some recent blocks but have worked around them and have good connectivity in China. We have sent you an e-mail to collect more information to better assist you.

Regards

Technical Support

Try Taiwan, South Korea servers. Works for me.