VyprVPN and High Sierra

Currently, I cannot access or connect VyprVPN using the OpenVPN or Chameleon protocols with the High Sierra OS. Any idea when this issue will be resolved?

Hello,

I’m sorry to hear that you have been experiencing connection issues with VyprVPN and I will be happy to assist with troubleshooting these issues promptly. I see the account is active so a connection should be possible at this time.

First, as I understand you’re on the latest version of Mac OS and encountering this issue when utilizing OpenVPN, I would like to know if you see anything from Golden Frog pending approval in System Extensions. This is a new issue on High Sierra that can impact OpenVPN and Chameleon VPN connections, as well as other features like Kill Switch, resulting in the dropped connection behavior you are seeing. Follow the steps below to see if you have a pending approval for Golden Frog.

Please attempt to connect with VyprVPN once more using the OpenVPN protocol.

Access the Mac Security & Privacy settings. (search for it with system search)

On the General Tab under the “Allow apps downloaded from:”.

You will see “System software from developer “Golden Frog” was blocked from loading”.

Click Allow and the connection and features should start working

If you still experience any difficulty, please contact us directly: support@goldenfrog.com

Regards,
Wes
Customer Support

Wes, I tried as you suggested and I did not see the prompt to allow Golden Frog. So this is still an issue… and I can only connect via L2TP protocol at this time.

Hello @Now_Trending,

Sorry to hear you are still having issues on your Mac.

If you still experience any difficulty, please contact us directly: support@goldenfrog.com

Regards,
Wes
Customer Support

Wes,
is this issue being adressed? And if so when might we see a resolve?

Hello @Now_Trending,

We have found steps that help resolve this. The extension issue typically is the cause of these problems. We’ve also found that the prompt in the Security and Privacy settings disappears after 30 minutes. If you had not tried connecting with either OpenVPN or Chameleon within the previous 30 minutes from when you tried the steps Wes provided you with could I have you try those steps again however use this order?

  1. Please attempt to connect with VyprVPN once more using the OpenVPN protocol.
  2. Access the Mac Security & Privacy settings. (search for it with system search)
  3. On the General Tab under the “Allow apps downloaded from:”.
  4. You will see “System software from developer “Golden Frog” was blocked from loading”.
  5. Click Allow and the connection and features should start working

If after trying these steps you find you’re still unable to connect we’d need to take a closer look at that and would need you to contact our support team directly via email at support@goldenfrog.com