VyprVPN CLI for Linux not working on Ubuntu 18.04

Hello I’m following the CLI tutorial for installing the CLI tool url and after installing when I try to log in with vyprvpn login and enter my credentials, I’m getting Login failed! I think its because my Linux version is 18.04. I have the cli working on another machine with ubuntu 16 and its ok.

Hello @superactro,
We apologize for the trouble logging in to the VyprVPN service via CLI on your 18.04 version of Ubuntu.

We’re aware of this issue with these newer builds of Linux. Our guides were configured using Ubuntu 16.04.1 While they might work with newer distributions, they are currently unsupported. Our Dev team is looking to add support for these newer versions in the future, however we do not have an ETA at this time.

We would suggest either using one of our manual OpenVPN or PPTP configuration guides linked below. If you are desiring to the CLI in the mean time you would need to install Ubuntu 16.


If you are in need of further assistance, please reach out to Support, they’re available 24/7 including holidays! https://www.goldenfrog.com/contact-support


Are there any updates on this? I’m also having Ubuntu 18.04 issues.

Hello @UnConundrum

Our Dev team is still looking to add support for newer versions of Ubuntu in the future, however we do not have an ETA at this time. Please try using one of our manual OpenVPN or PPTP configuration guides linked in the above post. If you are desiring to use CLI instead you would need to install Ubuntu 16.


As a happy, long time cli user of vyprvpn on ubuntu 16.04 and now just upgraded to 18.04. I would like to chip in one more vote, to have your dev team add an update. One: the cli has been very easy and convenient to use and two: it gives us the option to use the chameleon protocol. Hope this comes soon!!!

Thank you so much for the fantastic service so far!



We are working on updating the CLI application for Ubuntu 18.04 but do not have an ETA. We apreciate your patience!


Technical Support

1 Like

Let me also emphasize this request.
Please provide an update to the Linux CLI application as quickly as possible.
For me and all other users in China the CLI app with the Chameleon protocol is the ONLY possibility to setup a VPN connection from a Linux machine.

Hello @Stefan_Schober,

Thank you for your feedback! We appreciate your patience.

Can we subscribe to new release notifications by mail or is there a twitter stream where you keep people updated about the VyprVPN CLI for Linux?

Also, I would wish that Goldenfrog would treat the Linux CLI like the other connection solutions prominently at the control pannel. There, where the Android App, IOs App and Windows programs are listed. I can assure, that the Linux CLI has been one of the major selling points of your VPN solution. Thank you very much to the Linux CLI team within Goldenfrog!!! Keep developing!!! :heart_eyes:

Any news?

Hello @Weedshaker

At this time the CLI is still only available on Ubuntu 14.0.04, 14.10, 15.0.04, 15.10 and 16.0.04. Once an update is available the following article on our site will be updated

Please let us know if you have any further questions or concerns.

I think it’s actually an easy fix – using vyprvpn-linux-cli-1.7..deb, there’s a problem with the installed systemd service file /etc/systemd/system/vyprvpn.service

Specifically, as root, edit line 9 to have an absolute path, i.e.:

ExecStop=/usr/bin/killall vyprvpn_service

Save the file, reload using

# systemctl daemon-reload

and then follow the directions normally.

I tried to tell support about this nicely but “mia” simply hung up the chat on me. Sigh.


Yes! They shall put it on github if they are to lazy to maintain it. You are the perfect example that the community would fix it. :grinning:

Just installed the app and followed the instructions, restarted my machine, and the login worked perfectly! Thank you for posting the solution :slight_smile:

@DereK, would you like to comment on this one-line fix?


Sorry, Derek’s not available at the moment.

Many thanks to @baaka for posting this fix, and to @zkamvar for testing it out and confirming that it works!

I’ve passed this information along to our product team. We can’t be sure when the update will be ready, but I do feel sure that this information will be helpful.

Thanks again, and please let us know if you have any other questions or concerns that we can help with.

I’ve followed the steps posted by @baaka on my Ubuntu 18.04, othervise still informed with “401: Not Authorized”. I’m now locating in China Mainland, please suggest me how to solve it? Chameleon is vital for me, I need to login the CLI accessing this protocol.

Hello, sorry to hear you’re still having trouble with this. This is more likely being caused by Internet restrictions in China, rather than trouble with the CLI on newer Linux systems.

Unfortunately we can’t currently guarantee that logging into the CLI will work from within China. You’ll need to use the VyprVPN app for Windows, Mac, Android, or iOS while you’re in China.

How can there be no offical update instructions on Ubuntu setup of VyprVPN for Ubuntu 18.04 ? The instructions are still only updated for 16.04. The release date for 19.04 is April 2020.

Of course thanx for community users solving this and posting a fix, but as a company what are VyprVPN thinking ?. Problems like this should be fixed before OS’s are released and should take a few hours.