VyprVpn does not assign me IP

Hello, I’m going crazy for a problem with Tomato 140 and the VyprtVpn application installed on a Netgear R7000 router, the VPN is loaded but any nationality I choose does not give me the IP address.

I tried the Tomato versions, from 128 to 140, none worked.

I state that both the PC and the phone connected to the router with VyprVpn applications work well.
I am attaching photos of the problem.

I would be infinitely grateful if anyone could help me


Hey @Tantalio,

Thanks for reaching out to us!

This normally means that the router application cannot access the Goldenfrog API, so the application cannot retrieve the connected IP address. This is almost always caused by a DNS issue: The router application cannot access the goldenfrog API because the hostname cannot be resolved. The default name servers the router uses when it is not connected are not used during a VPN connection:

Please ensure that you are using VyprDNS, if that is already selected then please try changing your DNS settings in the Vyprpvn router application to 3rd party DNS instead of VyprDNS and then enter the following information in for the DNS server:

Primary DNS: 8.8.8.8 (Google)

Secondary DNS: 8.8.4.4 (Google)

You can also try OpenDNS servers:

Primary DNS: 208.67.222.222

Secondary DNS: 208.67.220.220

If you have any trouble after trying these steps, please contact our 24/7 support team via email or live chat so we can investigate: https://www.goldenfrog.com/support/

Regards,
Tyler | Golden Frog Support

This issue can be caused of many factors, try checking if you are having a DNS issue or in fact have no network once connected to the VPN. If it’s a DNS issue. please ensure that you are using VyprDNS, then please try changing your DNS settings in the Vyprpvn router application to 3rd party DNS instead of VyprDNS.

Thank you for answering me, but I do not understand where to set up VyprDNS

I note that by connecting with my android phone on the wifi network of this router I can safely use VyprVPN and also with my Windows PC works well.


Hello Tantalio,

Please use the following steps to change your DNS:

  1. Log into the firmware, disconnect from VyprVPN if the connection is active.

  2. Uncheck “Use internal DNS”

  3. Go to the Advanced section, then DHCP/DNS

  4. Add this into the dnsmasq custom configuration box:
    server=8.8.8.8
    server=8.8.4.4

  5. Save the change. Reconnect to VyprVPN.

If you’re still unable to connect please contact our support team at support@goldenfrog.com for further assistance.

Tried but it’s the same problem

with windows and android everything ok

@Tantalio Hello! We are very sorry for any delay. To properly assist you further with your router app issues, please reach out to our support team at: https://www.goldenfrog.website/contact-support. If you find you are unable to reach this alternate URL please email our support team directly at support@goldenfrog.com.

Regards,

Technical Support

Thanks HowardA for your interest in my problem but believe me before coming to ask for help here on the forum I have already contacted the support and never find a solution.
Even with Android I had problems and support did not give me any solution, I solved the problem by force of attempts, it was enough to change the password and I solved the problem.
It does not seem to me that the support works very well.

Thanks Tyler for the kind answer, but in the app for router / tomato there is no possibility to put the VyprDNS this is a possibility only for the application for windows and android