VyprVPN not working for Google sites

The connection seems to work fine when attempting to access servers via SSH or traceroute. Region locked video streams in JP or DE work fine. However, when trying to access Google sites, they’re able to bypass the VPN entirely, detecting my location, and loading instantly. DNS queries go through my default NIC, rather than the ones set in the TAP interface by VyprVPN. The default route (0.0.0.0/0) goes to my NIC as well, whereas only 0.0.0.0/1 goes through the VPN.

For the purpose of testing, I selected exit points that offer high latency. That way, if something is fast, I know it’s not going through the VPN. I am using Windows 10, with a fresh install of Firefox, along with noscript and ublock origin. I had read the advice about RTC, and changed that flag in Firefox as well. I have VyprVPN version 2.7.8.6317 installed. I had rebooted after installing it. Other than the exit point choice, all settings are default. My antivirus is Kaspersky and firewall is Comodo. Both were disabled during testing.

Would anyone have any advice to help diagnose what’s going wrong?

Hello Mikey,

In order to troubleshoot this matter effectively, our team recommends reviewing the following article on our support site to address your issue with Google-related services.

https://support.goldenfrog.com/hc/en-us/articles/205938498-Trouble-accessing-geo-blocked-content

If the issue persists after following the steps outlined on the article listed above, please provide us with additional feedback so that further troubleshooting may be conducted.

Best Regards,
Jordan

The linked article mentions 6 steps, so I will go through them here:

  1. It’s a fresh install of the browser. It’s not logged into anything. For completeness, I logged out on Chrome.
  2. Done.
  3. It’s a fresh install of the browser. There is no cache, cookies, nor temp files. For completeness, I still did the process of deleting nonexistent things.
  4. Did this several times.
  5. Done.
  6. Wired connection, no wifi.

Secret step 7: After doing the above 6 things, I also obtained a new IP from my ISP.

Google still sees me as in the US. DNS still defaults to my NIC rather than the tunnel. Default route still goes through my NIC rather than the tunnel.

Hello,

How are you determining that DNS queries for Google websites are bypassing the DNS servers setup by the VPN and are using the default DNS servers of your computer? If you could provide us with such information, as well as any screenshots or logs showing this, we would be glad to further troubleshoot by attempting to replicate the issue you are experiencing.

Additionally, if you are using VyprDNS setup within the VyprVPN app, can you please switch to using 3rd Party DNS servers, such as any of the below, and see if the issue continues.

Level3
209.244.0.3
209.244.0.4

Comodo Secure DNS
8.26.56.26
8.20.247.20

OpenDNS Home
208.67.222.222
208.67.220.220

SafeDNS
195.46.39.39
195.46.39.40

Regards,
Samuel

I mentioned DNS queries were going through my default NIC instead of the VPN, not just Google related DNS. This screenshot is with VyprDNS selected rather than 3rd party, Level 3 set via DHCP/NIC, while connected to the VPN:

https://gyazo.com/194ff43308b50b15fb5d03361c3fde00

With 3rd party selected (Comodo) through the VyprVPN tool, Level 3 set via DHCP/NIC, while connected to the VPN, it’s identical. DNS queries are not going via the VPN virtual NIC.

Here is a screenshot of the important bits from route print:

https://gyazo.com/5b5d47d64ca02c58a0d5fe0400380e0f

This is the ipconfig for the virtual adapter:

gyazo (dot) com/f382cbb440a7566c05d0286ce43831b7 (Forum software only allows two links)

And for my NIC:

gyazo (dot) com/3e7645faa2b45d70be7f66f27518e0e4

The bottom of a search query run in a clean install of Firefox, with rtc disabled, geolocation disabled, ublock origin and noscript installed, and VPN connected via JP:

gyazo (dot) com/1d307fd815a9757f7f0c6835a78a5703

With the VPN configured to connect via Korea, the behavior is identical. Google loads instantly, without VPN latency, and knows I’m in the US. The VPN does not appear to override the default route, nor default DNS. I had even tried to plop in an Intel pro/1000 just in case the realtek drivers were doing something naughty, but that had no effect.

Now for some odd bits. If I use Level 3 DNS on my default NIC and connect via Denmark or Sweden, Google thinks I’m in UAE. If I use OpenDNS on my default NIC, it thinks I’m in Germany. If I connect via any other exit point (JP, KR, BE, AU, etc), it thinks I’m in the US.

Hello @mikey,

Thanks for your report. I believe this is symptomatic of how Windows 10 selects DNS based off of the metrics, so the default DNS is identified with a higher metric than the DNS of the OpenVPN network adapter.

Try going through the Properties of the VyprVPN TAP adapter, select TCP/IPv4 Properties, Advanced, and set the metric value shown there to be a higher value than your native network adapter shows in the routing table, for example try setting it to 100.

You may also benefit from disabling IPv6 on the native network adapter if it is enabled by default.

After that is set, retry the OpenVPN connection through VyprVPN and identify if the DNS is being properly used by the connection and check the metrics through the IPv4 routing tables.

Let me know how this works for you!

Regards,
Keegan

Tricksy hobitses. Setting the metric for the VPN connection to like 5 fixed the DNS going through the wrong connection. However, Google stuff is still throwing me for a loop, and it’s well beyond my area of expertise. Google (and Youtube) are weird about geolocation. If I access via DK or SE, it thinks I’m in Germany. If I access via anywhere else, it thinks I’m in the US, even if I tinker with the Accept-Language heading. Network-wise, Google sites load instantly, whereas anything else has the latency you would expect with a VPN connection.

me too, your server is good, but i cannot play Black Desert Japan (blackdesert.pmang.jp) it still block my ip. it still can open the site, but cannot login. Because Japan Pmang API block it. And in the network connection center it show unidentified network, when i use another vpn service it will work fine. I was change metrix into 100, but nothing different.

The VPN connectivity and speed are good. But there is an issue which i’m facing. While using the VPN service it suddenly getting disconnected. I don’t know the actual reason but my i thought disabling my K7 Antivirus might help as it blocks VPN connectivity sometimes. Is there any fix for this so that i can still use it while keeping the firewall enabled?

Hello @David_Vitta,
Sorry to hear about the disconnects you are experiencing with VyprVPN.
You should be able to add a security exception to your AV program to prevent it from interfering with the VyprVPN connection. Those specific program settings are outside of our scope of support, however if you temporarily disable your AV and the issue persists go ahead and reach out to our Support department for further assistance.

This can be done by sending the connection logs from the VyprVPN app (go to Settings>Help>“Contact Support” or via our site: https://www.goldenfrog.website/contact-support

Thanks!

1 Like