VyprVPN now working on Raspberry Pi (Jessie) see how

Guys as its a problem putting in web links on this forum, where you see the [] brackets take them out.

I am hoping in the long run Golden frog will make a nice menu driven layout, but in the mean time, this works

Make a note of your current ip address
wget [http:]//ipecho.net/plain -O - -q ; echo

sudo apt-get install openvpn -y

sudo reboot

cd /etc/openvpn

(this like may not be necessary see below)
sudo wget [https:]//support.goldenfrog.com/hc/article_attachments/212052287/ca.vyprvpn.com.crt /etc/openvpn

sudo wget [https:]//support.goldenfrog.com/hc/article_attachments/214728647/GF_OpenVPN_10142016.zip

sudo unzip OpenVPN256.zip

ls

You now have two directorys OpenVPN160 and OpenVPN256 Differant levels of encryption I have used 2048 level Belgium

This code will save you putting in your details every time you load the program
sudo nano /etc/openvpn/vpncred.txt
enter username
password

Now open the ovpn file you have chosen
sudo nano /etc/openvpn/OpenVPN256/Belgium.ovpn
change the line below to:
auth-user-pass vpncred.txt
save

to start:
sudo openvpn /etc/openvpn/OpenVPN256/Belgium.ovpn

to stop
^C

To test the ip address has changed, open a new windows and run
wget [http:]//ipecho.net/plain -O - -q ; echo

=====================================================

Further notes from my friend, I have not tested
A couple of notes… You do not have to copy the “ca.vyprvpn.com.crt” to /etc/openvpn - the certificate is (aparently) embedded in all the *.ovpn files. Also, if you want to start your vpn client as a service at boot, you must follow these steps:

sudo cp Belgium.ovpn /etc/openvpn/vyprvpn.conf
sudo systemctl stop openvpn
sudo systemctl disable openvpn
sudo systemctl enable openvpn@vyprvpn
sudo systemctl start openvpn

Now openvpn will use /etc/openvpn/vyprvpn.conf as default config script during boot. Please note that the /etc/openvpn/vpncred.txt must exist and have the login credentials and the line “auth-user-pass vpncred.txt” must exist in /etc/openvpn/vyprvpn.conf

And a litte goldie is that if you want to change vpn-server to Germany (or whatever), you must simply modify the “auth-user-pass” line in Germany.ovpn to reference vpncred.txt and run the commands:

sudo cp Germany.ovpn /etc/openvpn/vyprvpn.conf
sudo systemctl restart openvpn

Hey @Nuttyman,

Thank you for the feedback you provided! We are working on putting together a guide for Raspberry Pi in the future. So we greatly appreciate the information you provided.

Regards,
Wes
Customer Support

Thanks for the instructions. I’ve just managed to do this on my RPi.

There are a couple of things that have changed since you wrote the instructions.

  1. The name of the zip file is now (as of 25 Oct 2017) GF_OpenVPN 10142016.zip

  2. I had to create the file vpncred.txt in the directory sudo nano /etc/openvpn/OpenVPN256/vpncred.txt

  3. The vpncred.txt file was empty until I inserted my VyprVPN username and password on two lines.

  4. It might be a good idea to check there is content in the selected *.ovpn file before using it. I chose Hong Kong only to later discover it was empty.

Apart from those few hiccups the VPN is working well

The name of the file changed again. there may be a newer version but a link that i found to work was:
https://support.goldenfrog.com/hc/article_attachments/360008728172/GF_OpenVPN_10142016.zip