VyprVPN Server cannot be contacted during registration

I’m deploying VyprVPN Server on VirtualBox. When I attempt to register the new server with step 20 on the tutorial, I get an error saying

“The VyprVPN server cannot be contacted. To troubleshoot: 1. Login to the VyprVPN Server via the console. 2. Verify the VyprVPN Server node is powered on.”

I am certain I’m using the correct Golden Frog login information when it throws this error. What would cause this error? And where exactly is the console I’m supposed to login from? I’ve tried logging out of Golden Frog then logging back in. I’ve also tried changing the password and re-attempting login.

Hi @Ross!

I don’t have access to Virtualbox presently to try and replicate this, but I suspect communication between your machine and our network is failing and presenting that error. I would verify the following:

  1. You have forwarded the appropriate ports, listed in the tutorial, to the correct local IP for the VM.
  2. You have temporarily disabled any firewalls (on the machine, on the router, etc) to see if you can register a server.
  3. You have verified you can log into and connect with the VyprVPN app on a device connected to the same network as the machine with the VM.
  4. You have deleted and remade the VM to see if the issue persists.

The console to which the error refers is the admin interface for VyprVPN Server, accessible via SSH over port 222. However, if the Server was offline, then the web interface wouldn’t load. So, I don’t foresee you needing to log into there just yet.

If you verify communication through the relevant ports is fine and firewalls aren’t blocking any connections, it may be helpful to send us the install log for VyprVPN Server to see if something went wrong during that process. You’ll need to log into the server itself via SSH as root, not the VyprVPN Server admin CLI. You can find the log here: /var/log/cloud-init-output.log (copy/paste the info in a text file)

In addition to the install log, the vyprvpn.log file may provide some insight into the issue. It is located here: /var/log/vyprvpn/vyprvpn.log You can also send this in using the option to contact support located in the web admin panel. However, if you encounter an error sending in a request that way, that would further indicate network issues with the VM, and you would need to send it in manually by copy/pasting the info into a doc and attaching it to an email.

If you can send that information to support@goldenfrog.com ATTN: Nick, I will have a look.

Thanks!

Nick
Golden Frog Support