Vyprvpnservice using 100% of one processor

The process vyprvpnservice (current version) is using 100% of one processor on my iMac (10.11.1). The problem appears each morning after the system was idle all night. I kill the process, terminate vyprvpn and restart vyprvpn and everything is fine for the day again. I get all VPN connection I want. Until next morning when the service using 100% of one processor again. The service is still sleeping at about 2am when I go to bed.

I made one change to my system recently. The default user got the admin privilege removed. Another dedicated user is used for the admin privilege. I need to enter the admin user with password to terminate the service in the morning from the default user as expected.

Hello @gn148178,

I am sorry to read that you are experiencing this issue with the vyprvpnservice using 100% of your CPU. In order for our Support Team to best assist you, can you please send in the VyprVPN logs by clicking Help from the menu bar with the VyprVPN app as the active window and then click Contact Support. When sending in the logs, please reference this post. Additionally, please let us know if the issue occurred with our previous versions of VyprVPN (if you recall).

Once we receive the logs, we will review them and continue troubleshooting the matter with you via your support ticket that will be generated upon you sending in the logs. After a resolution has been reached, feel free to update this post with the resolution so that other users experiencing the same issue may benefit from the resolution as well.

Thank you for your cooperation in this matter.

Samuel

Hi Samuel,

I started Vyprvpn and clicked on support in the help menu. The subject is “[Golden Frog Forum] [VyprVPN/Mac] Vyprvpnservice using 100% of one processor”. I hope the logs are attached automatically?

ps. I experience the problem since about 5 days.

Regards Reinhard

Hello @gn148178,

When using the Contact Support feature within our VyprVPN app, the checkbox to include the VyprVPN logs is checked by default. I do wish to confirm for you that your logs were received and that a response has been sent requesting that you provide a sample of the vyprvpnservice. Please continue to troubleshoot the issue via your support ticket.

Regards,
Samuel

Ok, this time a log should be attached

Did this get resolved? I’m having exactly the same issue when using Chameleon (running Yosemite)… I’m using a dual core Macbook Pro from mid 2012 and Vypr seems to be jumping onto one of the cores and pushing the temperature up to around 96 degrees…

Hello,

Thank you for contacting us via our official forums.

We would be more than happy to assist you with this issue.

Please contact our support team directly via the ‘Contact Support’ feature inside the application.

When you do this please refer to this forum post and also check the box that says ‘Include application logs’.

Regards,
Dustin
Golden Frog Support

Yes, the support asked me to uninstall everything and install a new version they were pointing to.
This are the instructions I followed:
Please visit this link: https://www.goldenfrog.com/vyprvpn/mac and download the .dmg file. Once you’ve downloaded the file, open it and scroll down. You will see an uninstaller. Run the uninstaller. Once the application is uninstalled, reboot your computer. You may return to the .dmg and install the application again. Once installed, try logging in and connecting.

Thank you…! Uninstalling and starting again seems to have fixed it - I hadn’t realised there was an uninstaller in the dmg… oops…

Same problem here…

After an indeterminate time, when I was using my mid-2012 Retina MacBook Pro running El Capitan connecting via OpenVPN 256bit, the fans started going crazy and the rear centre of the laptop got super hot very quickly. Happened daily, pretty much.

iStat widget showed GPU Diode temp getting to 92 degrees, and Activity Monitor showed vyprvpnservice as using over 100 and once, over 200%, of the CPU. Quitting vyprvpnservice caused the fans to go down and temperature back to the 40degree range.

Following info on gn148178’s post I uninstalled, downloaded and reinstalled v2.8.0.3745 No problems so far, and I assume all will be good… will post to the contrary if necessary.

As an aside, I was told that mid-2012 Retina macbook’s (and later) might have a problem with some aspect of their GPU, or some such, and there is a recall scheme in action for affected units.

Hello,

Thank you for contacting us via our official forum.

We apologize for the inconvenience this issue with the VPN service using 100% of your processor.

To start can you please e-mail the following information to us at the following address: support@goldenfrog.com

  • Did this occur with previous version of VyprVPN?
  • Where you doing anything specific when the CPU usage spiked. (Normal browsing, online gaming (more network intensive), etc…)
  • Can you please send us a “sample process” of vyprvpnservice, to do this follow the steps below:
  1. Start VyprVPN and connect to cause the CPU usage spike.
  2. Open Activity Monitor.
  3. Find or search for the vyprvpnservice process.
  4. Click on vyprvpnservice to highlight the process.
  5. Click the gear icon on the top right of the Activity Monitor window and choose “Sample Process,” enter your OSX password to authorize.
  6. When the sample is done being collected, click Save and then attach the saved file to your response so we can take a look.
  • Can you also access your VPN application and use the ‘Contact Support’ option to submit your application logs along with your process sample?

When you submit this information please reference this forum post so we can continue to assist you.

Regards,
Dustin
Golden Frog Support supervisor

I also had the same problem. MacBookPro (Retina, Mid 2012) OS X 10.11.2 vyprvnservice using 120% CPU time and fan running with just mail open (I only noticed high CPU usage after checking Activity Monitor to find out why fan was running so no idea if this was a new issue or not). The above solution helped, although I had the same version of VyprVPN installed as the suggested new install (2.8.0.3745) the uninstall and reinstall brought vyprvpnservice CPU usage down to 0%

On reinstall a vyprvpnservice.plist was placed in the LaunchDaemons folder.
I automatically monitor the LaunchAgents and LaunchDaeons folder and tend to delete most files placed there unless more clearly required by a frequently used app.

I am curious therefore what vyprvpnservice does and if it will affect running of VypVPN if I delete the LaunchDaemon plist?

Hello @gngdutch,

The following features of the VyprVPN application utilize the VyprVPN Service.

-The Kill Switch feature, which terminates network activity in the case that the VPN is not connected.
-The “Connect on unknown wi-fi” feature, which, with the feature
enabled, will check for changes in Wi-fi so that the VPN will know to
connect on unknown Wi-fi.
-The “Run on Windows start-up” and “Connect on Windows start-up” features.
-The “Connection Per App” feature, which, with the feature enabled, will check for applications starting up so that it will connect to the VPN if you have wither the use VPN or require VPN option checked for that specific app.
-Checking for application updates, which occurs once every 24 hours.
-The “Automatically send us non-personally identifiable app data”
feature, which helps improve application stability in future releases,
and is only relative to the use of the application itself
-The application will check (phone home) for a connection regularly to correct any app state issues.
-Additionally, having the VyprVPN Service run in the background makes loading the application considerably faster

If you delete vyprvpnservice.plist in the LaunchDaemons folder, none of the above features will work. Deleting this file may also cause additional problems with the VyprVPN app. We strongly recommend that you do not delete this file.

Samuel

Many thanks Samuel for clear description, indeed not a good idea to delete this vyprvpnservices.plist and functionality. Lets hope the clean install which seems to have reduced CPU usage (and need for fan) has solved the problem.

Appreciate your fast response !

Hello Dustin,

I am now running OS X 10.11.2 and VyprVPN 2.8.5.3904 and the behaviour has not occurred again. If it does, I will send a sample process as per your request.

Many thanks for your attention.

Hello @lux4life,

It is good to hear that you are no longer experiencing this issue with our latest version of the VyprVPN app for Mac, version 2.8.5.3904! If you should start to experiencing the issue again, please do collect a sample process of the vyprvpnservice and contact our 24/7 Support Team so that we can further assist you in troubleshooting this issue.

Regards,
Samuel

I, too, am getting the high CPU usage problem when running VyperVPN. This problem just started a few days ago. Activity Monitor on my iMac is showing VyperVPN consuming 105% or more CPU. I noticed it a few days ago when my iMac’s fan came on at high speed, which it never did until now.

I uninstalled VyprVPN and reinstalled it. This had no beneficial effect after restarting my iMac. Running VyprVPN is still consuming more than 100% CPU.

Rather than telling people to send a log file or reinstall VyprVPN, why not fix your software and then tell everyone here in this thread that you have fixed the problem? Otherwise, if you are not going to fix the problem, please cancel my service and issue a refund.

Hello @Wilderness

At this time our developers are investigating the cause of the High CPU Usage issue. We request log files from affected users so that we may gather as much information as possible to narrow down the cause of the matter. This is a crucial step to developing a fix to the software in these instances, and we appreciate your patience and cooperation throughout the process.

Currently, our development team is diligently looking into this issue and will push out an update to address this issue once it is ready. As of now I can tell you that a potential resolution is scheduled for our 2.9.5 release, however I cannot provide you with an exact date of the release.

For any account-related inquiries or requests, please contact us directly via live chat or email.

https://www.goldenfrog.com/contact-support

Let us know if we can answer any other questions.

Regards,

Katherine
Support Team

It’s still happening. VyprVPN is quit yet the vyprvpnservice is still running and using up 187% of my cpu. Why?

Hello!

We are forwarding an e-mail with instructions to address the High CPU usage issue you are seeing. Please reply to that e-mail for further assistance.

Regards,

Howard

Support Team